WordPress.org

Ready to get started?Download WordPress

Forums

Getting low contrast when uploading images created in gimp (13 posts)

  1. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Hi.

    I really hope anyone can help me with this issue. I am creating images with some text for a frontpage using Gimp. The image looks fine on my pc, but when I upload it to the website it becomes unclear. This happens wether I put the image into a slider or if I just put it directly into the website.

    I did not have this problem with photos before, only the ones I create in Gimp. I've tried jpg, png and even gif but with the same bad result.

    See the result here. This is how it looks on the website:
    http://alvoenkunst.no/forsteside-kladd/

    This is how it looks once you click the image to view it directly :

    http://i1.wp.com/alvoenkunst.no/wp-content/uploads/2013/10/malekurs-til-slider3.png

  2. esmi
    Forum Moderator
    Posted 9 months ago #

    I use GIMP all of the time to create images for sites and I have never had any problems inserting them into a WP site. Ask your hosts to check that the most recent version of GD Library is running on your server. Also, always upload images at the size that they will be used on the site.

  3. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Thx. Correction: The problem is not the photo itself, it is when I put text in the image, the text appears much clearer on the file on my pc than on the website. see http://alvoenkunst.no for example.

    The slider at the top has som letters on the right side and they look unclear. Anyone know if it's possible to fix this?

  4. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    That image is being resized - 695px × 243px (scaled to 968px × 338px) - which generally causes that kind of problem. Try creating the image in the size you need for the slider.

  5. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Thanks. I did what you said WPyogi. Same problem.

    1. I use meta slider with settings 1000px x 350px
    2. I create a new image in Gimp, with the same size
    3. I upload it to metaslider and install.

    So simple, I don't know what I am doing wrong?

  6. Matcha Labs
    Member
    Posted 9 months ago #

    WordPress automatically compresses images as they're uploaded. There are a few solutions, see:

    https://www.google.co.uk/search?q=wordpress+disable+image+compression

    hello.rob: If the source image and the slideshow size are the same, then meta slider will use the original image (without resizing). That won't stop WordPress from compressing the image during the initial upload though (see the link above for solutions on that)

    Regards
    Tom

  7. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Right. Will see what I can find out.
    Thanks a lot !

  8. Matcha Labs
    Member
    Posted 9 months ago #

    Rob: just checked your actual link.

    The source images are 2000 x 900px, so you need to set your slideshow size to that to stop meta slider from resizing the images. Don't worry about the slideshow coming out at 2000px wide - it's responsive so it'll scale down to fit your site.

    The other thing I can see is you're using a CDN of some sort, it looks like this CDN has some built in image compression. Try disabling that so Meta Slider uses unmodified images directly from your server.

    Regards,
    Tom.

  9. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    I have no idea what CDN is, but thanks. The problem however is the same if I upload an image without using the meta slider, so that eliminates the slider in this case.

    If I add an image to the site the text I put in with gimp still seems unclear.

  10. Matcha Labs
    Member
    Posted 9 months ago #

    CDN stands for content delivery network. I suspect you have JetPack installed(?) - try disabling the photon bit of it.

    Regards,
    Tom.

  11. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Sweet. That's right I have jetpack installed. Let me try that.

  12. helle.rob@gmail.com
    Member
    Posted 9 months ago #

    Thank you soooooooooo much! :D I disabled photon and problem solved !

  13. Matcha Labs
    Member
    Posted 9 months ago #

    Cool, no problem :)

Reply

You must log in to post.

About this Topic