WordPress.org

Ready to get started?Download WordPress

Forums

Delicious Readings
[resolved] Getting links from shortcode also in header (5 posts)

  1. eggepegge
    Member
    Posted 1 year ago #

    Hi. I just installed this plugin as it does exactly what I need. Almost ;)

    1) When using the shortcode in a page, the links are listed *before* the text I have on the page even though I have entered the text before the shortcode in the editor.

    2) I also get the links inside the <head></head> tag in the generated page. So far I have not really figured out why it ends up there as well. I have confirmed that is is the exact same code in delicious-readings.php that put it there though, as any changes to it is reflected both in the page content as well as the content output at the top of the page.

    See http://langbrovilla.se/test/ and you'll see what I mean. Here's how it has been entered into the editor:

    sweclockers
    [dreadings feed_url="http://delicious.com/v2/rss/egge/fiber" quantity=0 display_archive=0 new_tab=true]

    Thanks.

    http://wordpress.org/extend/plugins/delicious-readings/

  2. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Hi eggepegge,

    1) this is a bug, thanks for reporting it. I have just fixed it. Upgrade your plugin and test it.

    2) I can't reproduce it and I think that this could be something wrong in your theme or in a plugin. Try changing the theme temporarily and activating the Twenty Twelve theme instead. If it doesn't resolve, try deactivating all your plugins and leave active Delicious Readings only.

    Let me know.

  3. eggepegge
    Member
    Posted 1 year ago #

    Hi. Thank you for the quick response and fix. Great.

    1) v2.1 confirmed to fix this problem

    2) Tested on another site with another theme... should have done that first obviously. Do not show the same problem so I'll dive into the theme code instead.

    Again, thank you.

    /Thomas

  4. eggepegge
    Member
    Posted 1 year ago #

    Ehm... actually. After upgrading to 2.1 on the site I originally had problem #2 on, that problem is now gone as well :-) So seem to have been related to the #1 bug.

    Thanks again.

  5. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, it's related to #1 but something outside this plugin code echoes the output in the head section. For this reason I told you to look at your theme or other active plugins.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.