WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Getting internal server error after install (28 posts)

  1. womanwithmanyhats
    Member
    Posted 7 years ago #

    I'm getting a 500 Internal Server error after installing--I can't even get to my admin page.

  2. foolswisdom
    Moderator
    Posted 7 years ago #

    Just guessing, but possibly you uploaded the wrong/another .htaccess file?

    If you just have the one first try renaming it to something else and see if you still have an issue.

  3. womanwithmanyhats
    Member
    Posted 7 years ago #

    I took a look, and what has happened is that it did sort of a nested install. I'm deleting the new install and going to upload elements one by one and see if that helps.

  4. womanwithmanyhats
    Member
    Posted 7 years ago #

    Ok, now I'm getting: Warning: main(/home/content/e/l/v/mydatabasename/html/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/content/e/l/v/mydatabasename/html/wp-settings.php on line 100

    Fatal error: main(): Failed opening required '/home/content/e/l/v/mydatabasename/html/wp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /home/content/e/l/v/mydatabasename/html/wp-settings.php on line 100

  5. spencerp
    Member
    Posted 7 years ago #

    Make sure you've uploaded the following two files right:
    wp-includes/wp-db.php

    And: /wp-settings.php

    The first goes in the wp-includes/ folder.
    The second files goes into the blog's root folder, where the wp-config.php file is..

    spencerp

  6. womanwithmanyhats
    Member
    Posted 7 years ago #

    Still getting the message. I checked to make sure they were there, and then noticed that once again, I had the 2.1 Content file nested into my old content file. And I also noticed a Backup file in my root directory that I did not put there? I removed the extra content file and now the backup file is also gone, but still getting the exact same message.

    Thanks for the help, Spencer!

  7. womanwithmanyhats
    Member
    Posted 7 years ago #

    Oops, I take that back. The backup file is in my content. I specifically did the backup as a download when I did this last night, and I also did NOT nest any files manually.

    Could the backup be interfering with the program finding the right path?

  8. Samuel B
    moderator
    Posted 7 years ago #

    One of the files spencer mentioned must be corrupted. Maybe download fresh ones and upload again?

  9. womanwithmanyhats
    Member
    Posted 7 years ago #

    Ok, I'll give that a shot. I'm a pretty complete newbie at this. My first install of 2.0.6 was three weeks ago. Knowing this one was coming I didn't upgrade to .7.

  10. womanwithmanyhats
    Member
    Posted 7 years ago #

    WOW! This is aggravating, but thanks for all your patience. Now my page is coming up, http://www.womanwithmanyhats.com , but I first get an error message that stays on the screen after the theme loads, and there are no posts on the page. I'm not getting the setup link at all.

    Here's the error message: Warning: fopen(/home/content/e/l/v/my databasename/html/wp-content/cache/wp_cache_mutex.lock): failed to open stream: No such file or directory in /home/content/e/l/v/mydatabasename/html/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 94

    I'd rather not have my database name out there any longer!

  11. Samuel B
    moderator
    Posted 7 years ago #

    That message points to a plugin conflict. Try deactivating them then re-activating them one by one?

  12. womanwithmanyhats
    Member
    Posted 7 years ago #

    There aren't any activated. I do, however, have wp-cache as a plugin (not activated).

    And what about that backup? Is that an issue?

  13. spencerp
    Member
    Posted 7 years ago #

    Are you sure your wp-cache plugin was upgraded to the latest version?
    http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.1#W_-_Z

    spencerp

  14. womanwithmanyhats
    Member
    Posted 7 years ago #

    Nope, I hadn't done anything yet. On first upgrading, I was getting a 500 error and couldn't get into my site at all. This last effort produced my website, but no wp-admin/upgrade.php screen. So that's as far as I've gotten. I haven't upgraded anything other than WP itself yet.

  15. spencerp
    Member
    Posted 7 years ago #

    Oh ok, well make sure ALL of your plugins are compatible with 2.1 okay? If they aren't listed over here, contact the plugin authors to update them and add them to the page.

    http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.1

    Also, *some* might work regardless, but if they don't, disable them until the plugin authors update them.

    spencerp

  16. womanwithmanyhats
    Member
    Posted 7 years ago #

    Ok, I dropped the upgrade.php into my browser and it loaded, still with that message at the top of the screen, and all my posts are there again. I'll try upgrading my plugins and see if that works. Again, none have been activated; would it still be doing that if not?

  17. womanwithmanyhats
    Member
    Posted 7 years ago #

    Maybe another clue: I tried to activate Akismet first, and noticed it was still the old version; plus, clicking "activate" produced an error page, again referencing the cache. So I deleted my cache plugin, and then uploaded the current version of Akismet. Now I'm getting:

    Warning: main(/home/content/e/l/v//html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/content/e/l/v/mydatabasename/html/wp-settings.php on line 84

    Warning: main(/home/content/e/l/v/mydatabasename/html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/content/e/l/v/mydatabasename/html/wp-settings.php on line 84

    Fatal error: main(): Failed opening required '/home/content/e/l/v/mydatabasename/html/wp-content/advanced-cache.php' (include_path='.:/usr/local/lib/php') in /home/content/e/l/v/mydatabasename/html/wp-settings.php on line 84

  18. spencerp
    Member
    Posted 7 years ago #

    Are you SURE you've uploaded the files right? Also, please make sure your plugins ARE compatible with 2.1 okay? :);)

    If they aren't listed over here, contact the plugin authors to update them and add them to the page.

    http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.1

    Also, *some* might work regardless, but if they don't, disable them until the plugin authors update them. I would disable that CACHE plugin until you know for sure!

    spencerp

  19. womanwithmanyhats
    Member
    Posted 7 years ago #

    I deleted the cache plugin altogether, figuring it's easy enough to reupload if that was the problem, but it wasn't. It was after I did that I got that last error message.

    I also deleted advanced_cache.php.

    Still getting the exact same error, and once again can't get into my site at all.

  20. spencerp
    Member
    Posted 7 years ago #

    Send me an email with your login informations to: spencerp1 [at] gmail [dot] com

    I'll try and help you off the forums once. It's up to you though!

    spencerp

  21. womanwithmanyhats
    Member
    Posted 7 years ago #

    Now I have deleted all of my plugins, except the two I know are current.

    No change. Still getting a blank page with the same error messages.

  22. spencerp
    Member
    Posted 7 years ago #

    wp-content/advanced-cache.php

    Make sure the file is there?

    spencerp

  23. womanwithmanyhats
    Member
    Posted 7 years ago #

    It isn't there now, because I deleted it--but that was very late in the process. I mean, I did it right as I deleted all the plugins a few minutes ago. I thought perhaps WP was trying to find an old path it shouldn't have been looking for.

  24. spencerp
    Member
    Posted 7 years ago #

    Reupload it once, see what it gives next. I'm serious though, I could help you with this problem off the forums if you want..?

    spencerp

  25. womanwithmanyhats
    Member
    Posted 7 years ago #

    I did email you? For some reason people keep finding my emails in their canned ham boxes. :-)

    Do you mean reupload the whole thing, or just that file?

  26. spencerp
    Member
    Posted 7 years ago #

    Just that file.. :) I'll check my spam box n stuff. It'll be easier to do this off the forums.. ;)

    spencerp

  27. spencerp
    Member
    Posted 7 years ago #

    I got her back up and running again!

    http://www.womanwithmanyhats.com/

    I removed this line from her wp-config.php file first:
    define('WP_CACHE', true); //Added by WP-Cache Manager

    Brought her site back up. Then, downloaded the NEWEST version of the plugin from here:
    http://mnm.uib.es/gallir/wp-cache-2/

    Followed those directions and botta bing! It's done and good to go!

    spencerp

  28. womanwithmanyhats
    Member
    Posted 7 years ago #

    Thanks a BUNCH, Spencer! Now my DB name isn't out there for the world to see, and I can use the thing!

  29. spencerp
    Member
    Posted 7 years ago #

    Sorry replying to this so late, but, you're very welcome! If you ever need help again, just let me know! ;):)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.