WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Getting Error:Failed to send your message. Please try later or contact the admin (19 posts)

  1. Dhanashrikadam
    Member
    Posted 1 year ago #

    I am getting error Failed to send your message. Please try later or contact the administrator by another method.i tried lots of time then also i am getting this error can anyone help?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. djdealeyo
    Member
    Posted 1 year ago #

    I need the answer to this questions also [mod: no bump - if you have exactly the same problem, please post details]

  3. gabrielesque
    Member
    Posted 1 year ago #

    I'm trying to send a simple contact form but with a drop down menu using the pipe | symbol to hide 35 different choices of email recipients.

    ERROR MESSAGE: Failed to send your message. Please try later or contact the administrator by another method.

    I am also using SMTP via gmail which seems to work fine for other operations, so I presume this is a CF7 fail...

    Forms is located here: http://loudouniwla.org/host/contact-us/

    Any helpful hints?

  4. kgagne
    Member
    Posted 1 year ago #

    Ditto. I followed these instructions to generate this form code:

    [select your-recipient "Please choose a department|info@example.org" "Ticketing|tickets@example.org" "Auditions|auditions@example.org" "Production staff inquiries|staff@example.org" "All other inquiries|info@example.org"]
    
    <p>Your Name (required)<br />
        [text* your-name] </p>
    
    <p>Your Email (required)<br />
        [email* your-email] </p>
    
    <p>Your Message<br />
        [textarea your-message] </p>
    
    <p>[submit "Send"]</p>

    I too get this error message.

  5. kgagne
    Member
    Posted 1 year ago #

    Fixed! In my case, I'd filled out the "To:" field in where the resulting message should be sent with [your recipient], when it should've been [your-recipient] (note the dash).

    However, I'm not receiving the emails being sent through the form...

  6. gicolek
    Member
    Posted 1 year ago #

    Hey Guys,

    1. The following problem may appear as below:

    a. As above, for kgagne certain fields might be filled in with wrong values.
    b. Certain fields might not be filled at all.
    c. The hosting is wrongly configured. (it'd require admin support)

    2. Steps to fix that:

    a. Make sure that you run the latest CF 7 version.
    b. Try running the default contact form without changing any markup - if it works, go back to 1. and configure your own form accordingly.
    - if it doesn't work, then contact your hosting provider on what are the requirements CF7 is making usage of wp_mail function, which in exchange is making usage of php mail function. There are certain hosting providers for which this function might not work. After having the chat go back here.

  7. kgagne
    Member
    Posted 1 year ago #

    I've created a separate form that doesn't use the piped select your-recipient function; instead, I defined a specific email address for the message to go to. That form is working fine. Still no luck on the one whose code I posted above, though.

    I've disabled Jetpack's Feedback function, to eliminate any potential conflicts.

    -Ken

  8. kgagne
    Member
    Posted 1 year ago #

    OK, it's working now — I think Jetpack was indeed a conflict, but there was another dumb configuration error on my part that wasn't helping.

  9. gabrielesque
    Member
    Posted 1 year ago #

    Appreciate it. Oh, you are saying it's working with ALL the recipients. That has been my struggle. To find a form that actually does what it boasts, Email multiple recipients. Only I have 35 I need to address. Of course this morning I am locked out of my DB, and in deep deep waters for me. But I appreciate the feedback. I'll have to look into it again when I normalize.

  10. velexia
    Member
    Posted 1 year ago #

    I am also having this issue. The form was working when I built it in ecshelp.com/test but when I moved it to ecshelp.com is stopped working.

    I noticed the form ID changed and I fixed that but it still isn't working.

    Not sure, did I lose important information or data in the transfer?

    Everything else on the website seems to be working at the moment.

  11. velexia
    Member
    Posted 1 year ago #

    Never mind. I uninstalled the plugin and re-installed it and that fixed the problem.

  12. helencham
    Member
    Posted 1 year ago #

    Hi guys, having same issue. this is the code i have, but im not sure what went wrong with it.

    <p>Office to Contact*

    [select* office "Sydney | email.com.au" "Melbourne | email2.com.au"]</p>

    <p>Your Name*
    [text* your-name] </p>

    <p>Your Email*
    [email* your-email] </p>

    <p>Subject*
    [select* subject multiple "General" "Ticketing" "Sponsorship" "Others"]</p>

    <p>Your Message*
    [textarea* your-message] </p>

    <p>[submit "Submit"]</p>

    then in the mail, ive set the To: [office]

    ive tested the form with setting the To: field to my own email and that worked.

    Please help!

  13. ecampbell
    Member
    Posted 10 months ago #

    I had this same problem and it stemmed from when I changed the password on the email in settings.

  14. klipklopp
    Member
    Posted 10 months ago #

    I have updated to the latest version of Contact Form 7 and Word Press 3.6. I have four contact forms on my site - http://www.westminstertech.com. All were working before the updates, but now - none are.

    Any suggestions or help is GREATLY APPRECIATED!

    Thanks.

    Ted

  15. Lovepreet
    Member
    Posted 10 months ago #

    I uninstalled the plugin and re-installed it and that fixed the problem.

  16. Lovepreet
    Member
    Posted 10 months ago #

    i used email@mydomain.com and its stopped working. then i used gmail email id and now its working fine.

    Thanks
    Lovepreet

  17. adrian-pedraza
    Member
    Posted 10 months ago #

    Hi!
    I have the same form in two differents webs and it is working only in one of them.

    Here the code:

    <div class="form-element"><div class="form-title">Nombre<span class="required-asterisk">*</span></div>
    [text* your-name class:campo-texto]</div>
    
    <div class="form-element"><div class="form-title">Correo electrónico<span class="required-asterisk">*</span></div>
    [email* your-email class:campo-texto]</div>
    
    <div class="form-element"><div class="form-title">Organización a la que perteneces</div>
    [text organizacion class:campo-texto]</div>
    
    <div class="form-element"><div class="form-title">Perfil</div>
    [select perfil include_blank class:select-perfil "Emprendedor" "Investigador" "Inversor" "Docente" "Administrativo" "Ejecutivo" "Comunicación y prensa" "Otros"]</div>
    
    <div class="editions-form"><div class="form-title">Ediciones que te interesan<span class="required-asterisk">*</span></div>
    <div class="descripcion-editions">Selecciona las ediciones de las que deseas que te mantengamos informad@</div>
    [checkbox* editions "Argentina y Uruguay" "Brasil" "Centroamérica" "Chile" "Colombia" "España" "Francia" "México" "Perú"]</div>
    
    &nbsp; &nbsp;
    
    <div class="condiciones">[acceptance accept-this-1] <a href="#" target="_blank" onClick="window.open(this.href, this.target, 'width=970,height=400'); return false;">He leído las condiciones y acepto enviar este formulario</a><span class="required-asterisk">*</span></div>
    
    <p class="send-form">[submit class:submit-form "Suscríbete"]</p>
    <br />
    <p class="obligatorio"><span class="required-asterisk">*</span>Campo obligatorio</p>
    
    <span class="asunto-suscripcion">[text your-subject "Suscripción TR35"]</span>

    Any suggestions?

  18. buzztone
    Member
    Posted 10 months ago #

    @adrian-pedraza - If you are not contributing positively to the OP's issue, please start your own thread.

    As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  19. Olly - OWMC
    Member
    Posted 8 months ago #

    I am starting a new thread. The support/moderation is severely lacking here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic