WordPress.org

Ready to get started?Download WordPress

Forums

Getting error after install (5 posts)

  1. tordavis
    Member
    Posted 6 years ago #

    I get an error after enabling the cache

    get_wpcachehome() is having problems in line 45 of wp-cache.php with a redeclaration. Have you heard of this before?

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    No, try search through your plugins dir for that function ...

  3. tordavis
    Member
    Posted 6 years ago #

    that function is called in the wp-cache.php file. I'm running on IIS btw.

    Here's the full error text:

    Fatal error: Cannot redeclare get_wpcachehome() (previously declared in c:\Websites\digitalpickles115\thebitbag.com\wp-content\plugins\wp-super-cache\wp-cache.php:45) in c:\Websites\digitalpickles115\thebitbag.com\wp-content\plugins\wp-super-cache\wp-cache.php on line 44

  4. Donncha O Caoimh
    Member
    Posted 6 years ago #

    I don't know how that's happening. Somehow wp-cache.php is being included twice on your machine. That doesn't make sense.

  5. ddysart
    Member
    Posted 6 years ago #

    Did anyone figure this out? I'm getting the exact same error. Same setup - running on IIS. Also, FWIW I'm not using any re-write rules other than the 404 page hack (since my host doesn't support any real url re-writers)

    Granted, it was a bit of a challenge getting the plug-in up and running on IIS, I followed the steps listed here:

    http://neosmart.net/blog/2007/getting-wordpress-super-cache-to-run-on-a-windows-iis-or-apache-server/

    In addition to the clean-up in wp-cache-config.php shown there in step 8, I had to shorten the path since it duplicated what was already in ABSPATH.

    Nonetheless, the option page comes up, but if I try to make any changes on it, this error appears.

Topic Closed

This topic has been closed to new replies.

About this Topic