WordPress.org

Ready to get started?Download WordPress

Forums

Getting Desperate - SLIDERS, MENUS, EVERYTHING!!! (8 posts)

  1. CaramelBlue
    Member
    Posted 2 years ago #

    Hi,
    Posted on here last night and am now totally desperate for a solution - any solution!
    Have been unable to get Nivo Slider to work without slow page load and constant script error messages so have disabled it altogether on a theme that I bought which I thought really suited my needs (have tried everything - contacted author - no reply and scoured web & forums for help...but nothing!):
    Anyway as a last resort I've tried changing theme to a similar one 'Boldy' where Nivo Slider works better - Trouble now is all the work I've previously done doesn't show up as this theme has totally different menu structure (eg. Old theme had categories like 'Staff' and 'Testimonials' that you could add pages to but under new theme when I go to 'menus' under 'appearance' they're all inactive?); IS THERE A WAY I CAN MAKE ALL THESE PREVIOUS ITEMS SHOW WITHOUT ME HAVING TO DO IT ALL AGAIN????
    As I said in my 1st post I'd just like to repeat I'm a total newbie to WP so any help would be much appreciated. Many thanks in advance

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    You should be able to create any custom menu structure that you want via Appearance -> Menus. Perhaps you need to review custom menus?

  3. CaramelBlue
    Member
    Posted 2 years ago #

    Many thanks for taking the time to reply Esmi.
    To just confirm - I've already created the menu exactly how I want it (dropdowns, etc) using the old theme, but when I've replaced with new theme it won't display most of the items I've created because the new theme doesn't have some of the same default categories that the old one did (so when I go to Appearance - Menus, the ones that don't display when I view live site are 'greyed' out and say they don't exist)

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    the new theme doesn't have some of the same default categories that the old one did

    Post categories are completely theme-independent. As are custom menus created via Appearance -> Menus.

    and say they don't exist

    Ok - I'm officially confused. How can something that doesn't exist tell you that it doesn't exist? I've created dozens of custom menus but I've never seen any of the menu options greyed out. Can you be a little more specific?

  5. CaramelBlue
    Member
    Posted 2 years ago #

    Hi again, Yes - when I go to Appearance - Menus, all of the work I've done to create menu items such as categories and pages using 'Cleaner' theme are showing in panel but different colour to standard 'About us', etc pages that show up in new theme and the old ones are totally uneditable so don't show when I preview site using new theme???

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Can you replicate this using the Twenty Eleven theme?

  7. CaramelBlue
    Member
    Posted 2 years ago #

    Hiya, Do you mean recreate this from scratch using Twenty Eleven? I've just switched themes to that & same issue again, when I go to: Appearance - Menus, the items that I previously made in original theme are now all pink (not grey as mentioned before - sorry) and say 'invalid'; Also to give you a further idea, on right hand side of this page just underneath blue 'save menu' button & above all menu items this message appears in pink box: 'There are some invalid menu items. Please check or delete them.'
    As mentioned earlier I created the categories & pages using pre-set options such as 'Service', 'Testimonials' & 'Portfolio' that came with the theme I bought - 'Cleaner WordPress 2.0' and these automatically appear down left hand side of main dashboard when I activate this theme (when I change to another theme though these options disappear & so I can't edit under normal posts/pages/categories,etc and they're totally invalid on Appearance - Menus??
    I really don't want to have to recreate all this - is there a simple way, plug-in or similar theme that can assist me please?

  8. CaramelBlue
    Member
    Posted 2 years ago #

    Please, please can anyone help me with this further?
    I've decided I want to stick with the theme I've used from start (as I don't want to risk messing rest of site up!) and I simply want to get the Nivo Slider (see any of previous posts) that came with the theme working properly - it's just worked really slowly with this message: "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete."
    I've contacted (i) author - no response, (ii) site I bought theme from - responded, but no solution!, (iii) Searched web & forums - no solution!
    As a last ditch effort, as I've been making site in Firefox I downloaded 'Firebug'(although didn't really have a clue what to do with it!) and have now totally screwed site up - there's no slider at all & just a white space where it should be??? - so, I urge anyone, as I'm a WP newbie, to please offer me a simple, easy to follow solution to this? (will gladly send my log-in details via email or PM if this would help?). Many thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.