WordPress.org

Ready to get started?Download WordPress

Forums

Getting "Cheatin uh?" error previewing a theme (5 posts)

  1. Hirs
    Member
    Posted 1 year ago #

    Hi,

    Everytime I try to preview a theme or click to customize of the current theme I get the "Cheatin, uh?" error. When clicking to customize I can see the options window and in less than a second the error is shown.

    Looking for that problem I have found out many people is getting this error when uploading new images to the media gallery, I can upload images just fine.

    I'm using WordPress 3.4.2. I have tried disabling all plugins and with serveral admin users and blogs.

    Thank you.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

  3. Hirs
    Member
    Posted 1 year ago #

    Hi esmi,

    Thank you for the reply. I actually can switch themes fine, I'm using Twenty Eleven as well.

    All is working right except the "Customize" link by the current theme screenshot, (not "Theme Options" which is working), and the "Live Preview" link under each available theme (which is the same as clicking the screenshot)

    I'm using Domain Mapping plugin network wide, is the only plugin active, but I can't disable it as many blogs are using it (is a multisite setup)

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of your current version of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  5. Hirs
    Member
    Posted 1 year ago #

    Ok, I did a new installation, only copied wp-content, wp-config.php and .htaccess, I got the same result. I decided to start a new config from the sample config, and that was it!.

    I'm still finding out which line or lines were responsible (I left several config lines in the old config)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.