WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Getting an error message when I change anything (4 posts)

  1. bentoliza
    Member
    Posted 3 years ago #

    Hello

    I'm working to set up a new blog, and am having a hard time because when I do anything (even add or deactivate widgets, etc), I get the following message:

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/2/d222657943/htdocs/bentofun.net/wp-content/plugins/wptwitter/wptwitter.php:281) in /homepages/2/d222657943/htdocs/bentofun.net/wp-includes/pluggable.php on line 865

    The "pluggable.php" file is different every time. There have been several different files documented, but the warning about "cannot modify header information" is always the same.

    Any thoughts on how to fix this infuriating error?

  2. Samuel B
    moderator
    Posted 3 years ago #

    this is the file giving trouble
    /wptwitter/wptwitter.php:281
    deactivating the wp-twitter plugin will resolve it
    or you can try to figure out the headers already sent
    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

  3. bentoliza
    Member
    Posted 3 years ago #

    My hero!

    Thank you sooo much! Adios, wptwitter!

  4. millbank
    Member
    Posted 3 years ago #

    bentoliza,

    What most likely happened was that your wptwitter.php file has some spaces at the end of the code. If you edit the wptwitter.php file (it's in the plugins/wptwitter folder and remove any spaces after the last ?> then the message should go away. The absolute last thing on the wptwitter.php file needs to be ?> or you'll get the 'cannot modify header' error when you try to modify any of your posts.

    Hope that helps.

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic