WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
Getting a Google Maps API server has rejected Warning (9 posts)

  1. Oudin
    Member
    Posted 1 year ago #

    Hi,

    I've included my Google API Key,

    I also site wide https: enable (not sure if this is the cause of the problem)

    I'm getting the following error

    The Google Maps API server has rejected your request. The "sensor" parameter specified in the request must be set to "true" or "false"

    If I select "Turn Off SLP Maps" the error goes away however the map will be shown

    If I'm logged in it works fine no warning.

    http://wordpress.org/extend/plugins/store-locator-le/

  2. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    What version of SLP are you using? That was fixed many releases ago.

  3. Twansparant
    Member
    Posted 1 year ago #

    Same warnings here!

    As 'administrator' user I don't get the warning, but 'editor' users also get the exact same warning as above on every page and the Google map doesn't show up.

    I'm using the latest SLP version 3.8.8 and the Pro Pack.
    When I check 'Turn Off SLP Maps' the warnings do disappear like Oudin says, but the Google Map too.

    Am I supposed to turn any API services on in order to let SLP work properly? Because only the Google Maps V3 API Key is turned on.

    Thanks, Toine

  4. Twansparant
    Member
    Posted 1 year ago #

    Can you please post that fix then?
    Because I can't use my storelocator right now, visitors get a API warning on EVERY page load! Please help!

  5. Twansparant
    Member
    Posted 1 year ago #

    Sorry, jumped too conclusions too fast.
    It was a conflict with the Better WP Security plugin!

    If the option Display random version number to all non-administrative users under Other Tweaks is checked, non-admin users will get the Sensor API warning. I unchecked it and the warnings have disappeared!

  6. FahrenheitCG
    Member
    Posted 1 year ago #

    I'm getting the same sensor error (on a Mac in Safari and Chrome, but not in Firefox). SLP version 3.8.8, testing the standard version.

    We have the Better WP Security plugin installed as well, but turning off the "display random version number" box didn't seem to have an effect.

  7. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin is mangling URLS. In order for Google Maps to work the VERY FIRST parameter needs to be ?sensor=true or ?sensor=false. If that changes then Google will complain.

    BTW, the Google API key is essentially useless since Google updated their Maps API policy. You must have an AUTHORIZED Google Maps business account for the API to increase your request limits. In most cases leaving the API key field blank is better.

    For the record, I cannot get Google to even respond to my request for a business API key even though I'm a paying Google Business Apps subscriber. Not too happy about that. :/

  8. Oudin
    Member
    Posted 1 year ago #

    Version 3.8.7

  9. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @Oudin - that version is fine. Something else on your install is manglineg URLs. Use a browser dev tool and see how the Google Maps URL looks. If the first thing after the google domain is not ?sensor= then your URLs are mangled and you need to find out which of the other plugins (or the theme) is taking over the URL processing and breaking Google Maps calls.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic