WordPress.org

Ready to get started?Download WordPress

Forums

Getting 404s whenever clicking "category" and "archive" links (8 posts)

  1. dave404
    Member
    Posted 9 years ago #

    Hi, I just installed WordPress. I put in one post, set up a default category, permalink structure and archive setting. But whenever I click on my "category" and "archive" links I get a 404. What am I missing?

    Thanks,
    dave

  2. lawtai
    Member
    Posted 9 years ago #

    more info would be helfpul, but did you check to see if your .htaccess file is cmod to atleast 666

  3. dave404
    Member
    Posted 9 years ago #

    Whoops, that was stupid of me...
    my blog

    ".htaccess file is cmod to at least 666" is over my head. I'll see if the codex has anything on that.

    thanks,
    dave

  4. lawtai
    Member
    Posted 9 years ago #

    heh, well seeing how that part is "over your head" that's probably what you need to do. just use an ftp program and for a program like filezilla, just set the file attributes.

  5. dave404
    Member
    Posted 9 years ago #

    Yep, I was surprised to find how easy it was to change. Now that I've changed it, however, I'm still getting 404s.

  6. dave404
    Member
    Posted 9 years ago #

    UPDATE: okay, .htaccess and index.php have been set to 666. wp-content and its files and folders are 777. However, I notice that I still get "If this file was writable you could edit it." if I try to access the template. So clearly things are not getting written to my host, hence the 404s when clicking 'category' or 'archive' links.

    Any ideas?

  7. dave404
    Member
    Posted 9 years ago #

    SOLVED: My root directory and some internal files did not have the proper permissions set. Many, many thanks to Firas and helio7 on #wordpress irc for helping me out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.