WordPress.org

Ready to get started?Download WordPress

Forums

get_links in WP 2.1? (5 posts)

  1. Sainty
    Member
    Posted 7 years ago #

    I had this:

    <ul class="links">
    <?php get_links('3', '<li>', '</li>', '', 0, 'name', 0, 0, -1, 0); ?>
    </ul>

    But after 2.1 it isnt working. I've read in a post that get_links have been replaced in 2.1 with get_bookmarks, but it not working for me and the page for the tempe tag get_bookmarks isnt working either.

    What to do to make my sweet blogroll work again?

  2. Terry
    Member
    Posted 7 years ago #

    Sainty try this, it worked for me:

    <?php wp_list_bookmarks(); ?>

    If you need to adjust the variables, see if the same ones from the get_links work:

    http://codex.wordpress.org/index.php?title=Template_Tags/get_links

  3. cityofrain
    Member
    Posted 7 years ago #

    http://cityofrain.com/?p=736

    You need to eliminate the category apostrophe, and change it to your cat_id. See my example, and how I fixed it.

  4. dockarl
    Member
    Posted 7 years ago #

    Hi there Sainty - I note you've got Blix as one of your tags, so I assume you are having this problem with Blix theme. Try WordPress 2.1 Compatible Upgrade to fix your problems.

    Doc

  5. mmoncur
    Member
    Posted 7 years ago #

    I had the same problem - fixing the category ids per cityofrain's reply worked for me.

    Apparently the link categories have been merged into the same list as the post categories, so they have new category numbers.

Topic Closed

This topic has been closed to new replies.

About this Topic