WordPress.org

Ready to get started?Download WordPress

Forums

GET_EXCERPT HELP!!!! (4 posts)

  1. daneadkins
    Member
    Posted 1 year ago #

    Hi Folks,

    I will be grateful for any assistance with a little html issue....

    I am trying to remove the excerpts from my WP blog so that the entire content is displayed. I have perused the web for a resolution but have not yet been successful.

    The issue being, I don't have a loop.php file where I can simply change the 'get_excerpt' to 'get_content'? I am running a child theme and have the following code in a functions.php file:

    // custom excerpt ellipses for 2.9+
    function custom_excerpt_more($more) {
    return 'Read More ยป';
    }
    add_filter('excerpt_more', 'custom_excerpt_more');
    // no more jumping for read more link
    function no_more_jumping($post) {
    return ' <a>ID).'" class="read-more">'.'Continue Reading'.'</a>';
    }
    add_filter('excerpt_more', 'no_more_jumping');

    I am not sure if the problem lies in here somewhere or within the index.php file? This is what I have in the index.php:

    <div class="post-content"> <?php if ( has_post_thumbnail()) : ?> <?php echo '<figure class="thumb">'; the_post_thumbnail(array(520, 260)); echo '</figure>'; /* loades the post's featured thumbnail, requires WordPress 3.0+ */ ?> <?php endif; ?> <?php the_content(_('read more','phomedia'));?> </div>

    [please mark any posted code - http://codex.wordpress.org/Forum_Welcome#Posting_Code - part of the above code is already broken by the forum parser]

    Can anyone please provide some insight as to how to overcome this?? Keeping in mind that I am very new to this too.

    Thanks,
    Dane

  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

    your posted code already uses 'the_content()' which should give you the full content of your post (at least up to the 'more tag' if you have used it when writing the post).

    as you seem to be using the 'phomedia' theme by themeforest, please contact them for support.

  3. daneadkins
    Member
    Posted 1 year ago #

    Thanks for your reply Alchymyth.

    I have tried contacting Phomedia for support but haven't had much luck with responses, I'm not the only one either unfortunately.

    The posts only show the title, 55 words and then the custom 'continue reading'. I do not add any <!--more--> tags in the post or use custom excerpts and I still can't display all of the content.

    I will continue the search :)

    Cheers

  4. alchymyth
    Forum Moderator
    Posted 1 year ago #

    there is the possibility that your posted code is not from the template which shows the excerpts;

    try checking http://codex.wordpress.org/Template_Hierarchy to identify the right template.

Topic Closed

This topic has been closed to new replies.

About this Topic