WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] GET /wp-admin/jquery-1.10.2.min.map 404 (Not Found) (23 posts)

  1. Josh Levinson
    Member
    Posted 11 months ago #

    I get the error message GET http://example.com/wp-admin/jquery-1.10.2.min.map 404 (Not Found) in the admin, and a similar message on the front-end, with the exception that the script is attempted to be loaded from /wp-includes/js/ instead.

    This intermittently stops a WooCommerce extension I've been working on from doing things with javascript. My plugin does not load its own version of jQuery or anything foolish; it doesn't load or require anything beyond what WordPress and WooCommerce ships with. Sometimes my javascript will work, other times it will not. I cannot reliably reproduce unique situations that cause the two separate results.

    I am using TwentyTwelve with only two plugins active - WooCommerce and my own plugin.

    This problem did not occur before upgrading to 3.6.

  2. markfink
    Member
    Posted 11 months ago #

    +1
    I see the same issue. I do not currently need the map for debugging but you are supposed to have it when using the minimized jquery version.
    If you do not want to provide the map you have to remove the reference.

  3. benjaminprojas
    Member
    Posted 11 months ago #

    I also have this same issue on a brand new install of WP 3.6, no plugins activated, debug mode off, Twenty-Thirteen Theme.

    Any way to fix this?

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    @benjaminprojas: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  5. benjaminprojas
    Member
    Posted 11 months ago #

  6. skoblenick
    Member
    Posted 11 months ago #

    Simple fix for this:

    This error can be 'fixed' by removing the comment on line 2 of the jquery. Change the following:

    /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license
    @ sourceMappingURL=jquery-1.10.2.min.map
    */

    to:

    /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license */

    See my response on here as well: http://bugs.jquery.com/ticket/14225#comment:2

  7. benjaminprojas
    Member
    Posted 11 months ago #

    we shouldn't need to modify core files in order to fix this, but thanks for the easy fix.

  8. paul.irish
    Member
    Posted 10 months ago #

    @benjaminprojas the real fix is just to include the .map file in the place it belongs.

    download http://code.jquery.com/jquery-1.10.2.min.map and toss it in!

  9. Josh Levinson
    Member
    Posted 10 months ago #

  10. wpthemesidea
    Member
    Posted 10 months ago #

    Yes rskoblenick, but don't delete the row just change from :

    /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license
    //@ sourceMappingURL=jquery-1.10.2.min.map
    */

    to

    /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license
    *@ sourceMappingURL=jquery-1.10.2.min.map
    */
  11. Josh Levinson
    Member
    Posted 10 months ago #

    @wpthemesidea - that is incorrect. Please reference http://core.trac.wordpress.org/ticket/24994 and the attached patch - http://core.trac.wordpress.org/attachment/ticket/24994/24994.patch. The ticket and patch state to remove the line completely.

    The real fix is to make the changes as shown on the patch: http://core.trac.wordpress.org/attachment/ticket/24994/24994.patch

    That is what will be done in the next release.

  12. wpthemesidea
    Member
    Posted 10 months ago #

    ok, I see your link, thanks josh

  13. sheriffderek
    Member
    Posted 10 months ago #

    I'll have to agree with Paul. Just drop it in. Tada!

  14. Aaron T. Grogg
    Member
    Posted 10 months ago #

    @paul.irish & @sheriffderek:
    what happens with the next WP upgrade? that files gets nuked again, right?

  15. juanp_1982
    Member
    Posted 10 months ago #

    I was able to fix it by modifying the second line (as it was suggested) but I added the URL of the file.

    /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license
    //@ sourceMappingURL=http://code.jquery.com/jquery-1.10.2.min.map
    */

    @Aaron T. Grogg: yes, this is just a temporary solution but it's better than nothing :-p until WP fix it themselve

  16. Josh Levinson
    Member
    Posted 10 months ago #

    Please stop posting incorrect fixes.

    The only correct fix for this, and the one that should be implemented by all in this thread, is the one that will be put into effect by the next WordPress update.

    http://core.trac.wordpress.org/attachment/ticket/24994/24994.patch

    The red is what was, the green is what will be.

  17. Aaron T. Grogg
    Member
    Posted 10 months ago #

    It's a shame that a formal release change will be to completely disable jQuery mapping, and not to simply add the map file...

    Is adding the file so much more difficult?

    Or even better, couldn't mapping fail a little more gracefully?

  18. Josh Levinson
    Member
    Posted 10 months ago #

    As nacin said on the ticket (http://core.trac.wordpress.org/ticket/24994), WordPress ships with jquery.js, not jquery.min.js.

    The entire point of a source map is to debug minified code. In this case, the code is not minified, and negates the need for a source map.

    Also, to clarify my original post - this error in no way interfered with my JS. That was just my initial (and foolish/incorrect) assumption.

  19. asdevargas
    Member
    Posted 10 months ago #

    Hi! I follow the instructions provided on http://core.trac.wordpress.org/attachment/ticket/24994/24994.patch, the error disappeared, but I still have 1 warning (but I can't see what it is, it's just the icon showing on bottom right with this number). Anyhow, thanks for the solution :) hope it will get fix on next release.

  20. jonatanvictor
    Member
    Posted 10 months ago #

    Hi! I did what you said Josh. And the warning disappeared. But there's still something wrong that I can't figure out. All pages except the front page is blank, and that includes the pages in admin where I list all pages and posts.

    Don't understand that one :/

    Oh... the address is pancakechurch.com

  21. webaware
    Member
    Posted 10 months ago #

    If you want Google Chrome to load the map file, and get rid of the 404, install/activate the Use Google Libraries plugin. jQuery will be loaded from Google's CDN (at the correct version) and Chrome's developer tools will know where to find the .map file.

    cheers,
    Ross

  22. topquarky
    Member
    Posted 10 months ago #

    Be it resolved that:

    Installing YAP (yet another plugin) to fix something that will certainly be addressed in the next release of WP (yay Automattic), just slows us down.

    I didn't know about 'mapping' until this came up, so thanks for introducing me to the idea.

    Removing the line or obfuscating the line makes no difference.

    For me, I changed it to:

    *\@\ \s\o\u\r\c\e\M\a\p\p\i\n\g\U\R\L\=\j\q\u\e\r\y\-\1\.\1\.\2\.\m\i\n\.\m\a\p

    ...merely for the poetry.

  23. webaware
    Member
    Posted 10 months ago #

    @topquarky: installing Use Google Libraries will most likely improve your website performance :)

    cheers,
    Ross

Reply

You must log in to post.

About this Topic