WordPress.org

Ready to get started?Download WordPress

Forums

get rid of /wp in my domain (10 posts)

  1. obanjoobi
    Member
    Posted 1 year ago #

    I would like to get rid of the /wp in my domain. Apparently I did something wrong upon my wordpress installation so that my domain is now http://weitzelbanjo.com/wp/ . The forum posts I could find talk of moving index files or changing an index.php to an index.html or moving files to a different directory. I tried moving a few things last night, but apparently messed things up. After it didn't work, I moved things back where they were, but then, this morning, I could not even access my admin page. I called my host support (webhostingpad). They finally got my files back in order to access my admin, but said to get rid of the /wp I would have to completely uninstall wordpress and re-install it correctly, which would lose all my work I did on the site. Or they could move the appropriate files for $20 without losing anything. If someone can guide me through what I need to do in very beginner terms, it would be much appreciated. Or is it really worth the $20? Thank you!

  2. Greg
    Member
    Posted 1 year ago #

    You don't have to uninstall it, there is a way to move your installation. Check out this document: http://codex.wordpress.org/Moving_WordPress#On_Your_Existing_Server

  3. obanjoobi
    Member
    Posted 1 year ago #

    Thanks,
    I found this already and am stuck again. I cannot do step 4 because the wordpress url and site url (under settings>>general) are locked. They weren't that way when I looked at them last night, but after talking to webhosting pad this morning, they became locked. I called them back just now to ask why and they can't seem to figure it out, just told me to open a support ticket. I think they are trying to force me into paying them the $20 to use their "wordpress file transfer service". Hopefully these will be unlocked now as I have little intention on paying them at this point (and probably moving my host after my term is up).
    I am a little unclear exactly which files I will need to move and am wary of screwing things up again, but I'll back up as much as I can and give it a try as soon as I can.

  4. Greg
    Member
    Posted 1 year ago #

    You can override that by adding (or editing) the SITEURL and HOME variables in your wp-config.php file:

    define('WP_SITEURL', 'http://example.com/wordpress');
    define('WP_HOME', 'http://example.com/wordpress');

    See:
    http://codex.wordpress.org/Editing_wp-config.php#Advanced_Options

    Then proceed to step #5.

  5. obanjoobi
    Member
    Posted 1 year ago #

    Thanks.
    I went into the wp-config.php file and found that the code was already there. I checked the backup of this file from when I had created it and those lines weren't there. So I guess that is proof that the webhosting pad folks them. When I deleted those lines, I was able to then edit them through the admin>settings>general tab. I will now try to follow the rest of the steps.

  6. obanjoobi
    Member
    Posted 1 year ago #

    I just want to insert an apology for speaking too quickly about webhosting pad. After further thought, I realize that they had inserted that code as a way for me access my admin this morning after I messed it up last night. I am now sure that they had no ill intentions about forcing me give them $20. Sorry!

  7. obanjoobi
    Member
    Posted 1 year ago #

    Ok, well everything got moved and my site opens without the /wp, as I'd hoped. Everything but the images, that is. My nextGEN galleries are all there, but anything that draws from my wordpress media library won't show. The codex says to check the 'store uploads folder' under settings>media, but there is no such thing on my admin>settings>media. I uploaded the Velvet Blues Update URL plugin and ran it with no effect. Anything else I can try? I can't even seem to find a way to change the individual URL's for images one at a time.

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Looks like the image paths are not changed - on your home page this is one - no image found there:

    http://weitzelbanjo.com/wp/wp-content/uploads/2013/03/copy-Header-logo-and-burl-2.jpg

    And if I try this in a browser, it works to show the image:

    http://weitzelbanjo.com/wp-content/uploads/2013/03/copy-Header-logo-and-burl-2.jpg

    Maybe try the Velvet blues updater again.

  9. obanjoobi
    Member
    Posted 1 year ago #

    I have tried the velvet blues updater again, updating every category it allows. When I go the the media library and look at the image url's they look correct, likehttp://weitzelbanjo.com/wp-content/uploads/2013/03/copy-Header-logo-and-burl-4.jpg
    but when I go to the site and "inspect element" from my browser, the url for the image is http://weitzelbanjo.com/wp/wp-content/uploads/2013/03/copy-Header-logo-and-burl-4.jpg
    If the url has been changed in the media library, I have a feeling that even if I delete all my images and re-upload them, my files will still read them wrong. Somehow, i need to change all of the links to them...help?

  10. obanjoobi
    Member
    Posted 1 year ago #

    So i went in and manually changed every image link in all of my pages and go the images to show, EXCEPT for my Header. I had 4 rotating images in my header. I deleted them all and re-uploaded them and still no images showing. There must be a file that is keeping that link routing through the old file. Where could it be? I looked in my header.php and could not find anything that looked like it would be doing that, but then I really do not know what I am looking for.

Topic Closed

This topic has been closed to new replies.

About this Topic