WordPress.org

Ready to get started?Download WordPress

Forums

Responsive
[resolved] Get rid of the "archive" widget (8 posts)

  1. dirgis
    Member
    Posted 1 year ago #

    Hi there,

    I am a fairly new wordpress user, but I kind of worked my way around the responsive wordpress theme.

    However, I can't find a way of getting rid of the archive-widget on the page with all the posts. Here is the link:
    http://www.myck.co.uk/centralinspiration/work-in-progress/

    I would be grateful for any help - where I have to alter the code to get rid of it without destroying everything.

    Thank you very much!!

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    In general, you can change widgets on the Widgets screen:

    http://codex.wordpress.org/WordPress_Widgets

    Is that not working?

  3. dirgis
    Member
    Posted 1 year ago #

    Hi Wpyogi,

    thanks for your reply.

    Unfortunately it is not working. I didn't put the archive widget into any of the pages, but it still appears on the one with posts. I guess I would have to alter one of the html/php or javascripts, but I am concerned that I would destroy something or that it could affect another page where I am using image widgets.

    Any idea on how I could solve this? I would be really grateful…

    Cheers, Dirgis

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    There may be something specific to the theme, yes, and I'm not that familiar with it. I'd suggest visiting the theme's dedicated forums here:

    http://cyberchimps.com/forum/free/responsive/

  5. dirgis
    Member
    Posted 1 year ago #

    Hi again,

    the solution was fairly simply in the end:

    (Theme options - default layout)
    Just change the "Default Single Blog Post Layout"
    to "Full page (…)".

    Problem solved.

  6. PeterBurgin
    Member
    Posted 1 year ago #

    For anyone with this problem who needs sidebars, remove or comment out the following code in sidebar.php

    <?php if (!dynamic_sidebar('main-sidebar')) : ?>
    		<div class="widget-wrapper">
    
    			<div class="widget-title"><?php _e('In Archive', 'responsive'); ?></div>
    				<ul>
    					<?php wp_get_archives( array( 'type' => 'monthly' ) ); ?>
    				</ul>
    
    		</div><!-- end of .widget-wrapper -->
    		<?php endif; //end of main-sidebar ?>

    This should fix the problem though archive shows if you don't have another widget in there.

  7. IAmTam
    Member
    Posted 1 year ago #

    So would you create a sidebar-child.php file and then enter this code? Does that work? Or is it only css files that override like that?

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @IAmTam - the best place for help with Responsive is on their forums here:

    http://cyberchimps.com/forum/free/responsive/

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic