WordPress.org

Ready to get started?Download WordPress

Forums

I get logged out when I view site from dashboard (5 posts)

  1. SleepyJohnW
    Member
    Posted 4 years ago #

    Blog all seems to work fine apart from this problem. I can login OK and do whatever admin I want but if I click View Site while in the dashboard it throws up the site with me logged out.
    There seems to be something in the database causing this as it did not happen when I first installed, and when I reinstalled it worked fine until I pointed the blog to the old database, when the problem showed up again. Anyone any ideas? I cannot remember what I did just prior to the problem showing up. I have tried disabling all plugins and changing admin theme.
    When I back arrow to the dashboard I am still logged in.

  2. figaro
    Member
    Posted 4 years ago #

    when I reinstalled it worked fine until...

    Did you change the location of the blog on the reinstall? Or, maybe change one of the url in your admin Settings/General area?

  3. SleepyJohnW
    Member
    Posted 4 years ago #

    Yes I did at first. I got it running and all was well, then I think I deleted the duff installation, renamed the new one as the original then pointed it to the original database, or something along those lines. I have peered into the database but can see no clues. I also find that I cannot review a draft post - wordpress cannot find it - and wonder if that is connected. Any idea if this can be put right? It is a real nuisance, if only because all my visits are clocking up in the stats.

  4. SleepyJohnW
    Member
    Posted 4 years ago #

    Well, I don't know what the problem was but I fixed it by making a clean new install into an empty folder and set up an new empty database. I then exported all the posts etc from the old site, copied the plugins over and after a little fiddling I have an identical site that enables me to stay logged in. I suspect you were right figaro, the moving of the site perhaps screwed up some link or other. Thanks for that clue.

  5. ostenfeldt
    Member
    Posted 4 years ago #

    Changing the url in my admin settings did the trix for me :-)

Topic Closed

This topic has been closed to new replies.

About this Topic