WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] Get HTTPS to be default for css/fonts/images (4 posts)

  1. supah
    Member
    Posted 1 year ago #

    Lost on where to tweak this.

    My settings are set properly for https at
    http://(myurl)/wp-admin/options-general.php

    HOWEVER, when I check the "System Status" at http://(myurl)/wp-admin/admin.php?page=woocommerce_status it says"

    Home URL: https://(myurl)
    Site URL: http://(myurl)

    I don't know where this is breaking. I've tried the plugins to get everything to switch to https, but it doesn't "take".

    http://wordpress.org/extend/plugins/woocommerce/

  2. supah
    Member
    Posted 1 year ago #

    i added <link href='https://fonts.googleapis.com/css?family=Varela+Round' rel='stylesheet' type='text/css'>
    to the header in header.php but i know this is a shoddy fix.

    I want to know where and how these urls are called in. this is terribly frustrating.

  3. Patrick Garman
    Member
    Posted 1 year ago #

    I'd suggest just using the Force SSL option of WooCommerce and dropping any other HTTPS forcing plugins. Then you would want to enable Unforce SSL as well because SSL on at all times isn't that great for performance ;)

    When in SSL WordPress will automatically make all properly enqueued assets load via HTTPS, if your google font is loading over HTTP instead you may have it hard coded instead of enqueued.

  4. supah
    Member
    Posted 1 year ago #

    Hey Patrick!
    Thanks so much for the suggestions, and you're right - it should have worked with the forcing, but it would break the styles etc. I used every which setting set up possible and none of them solved the problem. If I could have found where the dynamic code was generated and alter it, i would have done that, but for my skill level: wordpress plus my theme plus my woocommerce plugin means so much dynamic stuff that I was unable to find it. Probably the combination of developing the site pre-ssl plus having a shared host on networksolutions was the issue that made all the logical solutions such as your suggestion fail.

    Overnight I found this solution and it's solved all my problems - A this plugin http://snippets.webaware.com.au/snippets/wordpress-is_ssl-doesnt-work-behind-some-load-balancers/
    The problem was actually this function is_ssl(), and this plugin did the trick.
    Go team! thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic