WordPress.org

Ready to get started?Download WordPress

Forums

get an error message when try to post comments (12 posts)

  1. lindiwe
    Member
    Posted 2 years ago #

    Hi,

    I installed wordpress locally then moved online everything was fine untill i tried to post a comment, everytime when i click on the post comment button i get an error message as "Not Found

    The requested URL /home/womenofe/public_html/^http://41.135.150.201/$ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request." I am not sure if whether while was moving my wordpress something might have gone wrong or if there is a file that needs to be updated within my wordpress please advise

  2. Tim S
    Member
    Posted 2 years ago #

    It looks like you have not updated the site URL and home settings after the migration. Here's an article on it you may find helpful:

    http://codex.wordpress.org/Changing_The_Site_URL

  3. lindiwe
    Member
    Posted 2 years ago #

    Hi Tim,

    I have checked that and everything is my site was updated

  4. Tim S
    Member
    Posted 2 years ago #

    Your URL should not display the IP address unless you are using that. Your site URL setting should be pointed to your domain name.

  5. lindiwe
    Member
    Posted 2 years ago #

    The thing is i was using instsnt wordpress locally on my pc then expoted everything from my local to the server, i was able to find others where i needed to change the url like images,and so on but with my posts i can see that it points to an IP address instead of doamin thats why it gives an error and i dont know where to change that cause ive been searching through all my file hopng to find a place where my url ponts to ip rather than domain name but no luck, so if maybe you could help me in finding the file that needs to be changed.

    thank you

  6. lindiwe
    Member
    Posted 2 years ago #

    can anyone help please!

  7. Tim S
    Member
    Posted 2 years ago #

    Try a few things. Anytime you migrate a WordPress site you need to update your permalinks. Log into your dashboard and reset your permalinks. Also, verify that the Site URL is correct for your domain.

  8. lindiwe
    Member
    Posted 2 years ago #

    I did update my permalinks, but i still do get the 404 error but in adifferent way i get the error within my wordpress site but with the "http://www.womenofeden.co.za/%5Ehttp:/41.135.150.201/" as a url m not sure where does the /%5Ehttp:/41.135.150.201 come from or lies

  9. lindiwe
    Member
    Posted 2 years ago #

    Thanks, got the solution Tim. I first deactivated all my plugins then went and deleted my .htaccess file from the server then loged in again in my admin chaged my permalinks to custom then activated my plugins again then everything was fine, thanks a lot

  10. Tim S
    Member
    Posted 2 years ago #

    I'm glad you got it resolved.

  11. ne0bi0
    Member
    Posted 1 year ago #

    I have the same problem. I have checked the permalinks but I still get the same error.

    I read somewhere else that the problem can be related to the htaccess file, but not sure how to proceed. Is there a generic htaccess file I can update to overwrite the current one?

    This is my current htaccess file (if i replace the generic yourdomain.com with my real domain turismo-sostenible.net then, the site will give me a 500 error)

    protect the htaccess file
    <files .htaccess>
    order allow,deny
    deny from all
    </files>

    disable the server signature
    ServerSignature Off

    limit file uploads to 10mb
    LimitRequestBody 10240000

    protect wpconfig.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    who has access who doesnt
    order allow,deny
    deny from 000.000.000.000
    allow from all

    custom error docs
    ErrorDocument 404 /notfound.php
    ErrorDocument 403 /forbidden.php
    ErrorDocument 500 /error.php

    disable directory browsing
    Options All -Indexes

    redirect old to new
    Redirect 301 /old.php http://www.yourdomain.com/new.php

    block referring domains
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} digg\.com [NC]
    RewriteRule .* – [F]

    disable hotlinking of images with forbidden or custom image option
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?yourdomain.com/.*$ [NC]
    RewriteRule \.(gif|jpg)$ – [F]
    RewriteRule \.(gif|jpg)$ http://www.yourdomain.com/stealingisbad.gif [R,L]

    php compression – use with caution
    <ifmodule mod_php4.c>
    php_value zlib.output_compression 16386
    </ifmodule>

    set the canonical url
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^yourdomain\.com$ [NC]
    RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [R=301,L]

    protect from spam comments
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*yourdomain.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

  12. ne0bi0
    Member
    Posted 1 year ago #

    I have the same problem. I have checked the permalinks but I still get the same error.

    I read somewhere else that the problem can be related to the htaccess file, but not sure how to proceed. Is there a generic htaccess file I can update to overwrite the current one?

    This is my current htaccess file (if i replace the generic yourdomain.com with my real domain turismo-sostenible.net then, the site will give me a 500 error)

    protect the htaccess file
    <files .htaccess>
    order allow,deny
    deny from all
    </files>

    disable the server signature
    ServerSignature Off

    limit file uploads to 10mb
    LimitRequestBody 10240000

    protect wpconfig.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    who has access who doesnt
    order allow,deny
    deny from 000.000.000.000
    allow from all

    custom error docs
    ErrorDocument 404 /notfound.php
    ErrorDocument 403 /forbidden.php
    ErrorDocument 500 /error.php

    disable directory browsing
    Options All -Indexes

    redirect old to new
    Redirect 301 /old.php http://www.yourdomain.com/new.php

    block referring domains
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} digg\.com [NC]
    RewriteRule .* – [F]

    disable hotlinking of images with forbidden or custom image option
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?yourdomain.com/.*$ [NC]
    RewriteRule \.(gif|jpg)$ – [F]
    RewriteRule \.(gif|jpg)$ http://www.yourdomain.com/stealingisbad.gif [R,L]

    php compression – use with caution
    <ifmodule mod_php4.c>
    php_value zlib.output_compression 16386
    </ifmodule>

    set the canonical url
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^yourdomain\.com$ [NC]
    RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [R=301,L]

    protect from spam comments
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*yourdomain.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

Topic Closed

This topic has been closed to new replies.

About this Topic