WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
[resolved] Genericons font for SM icons not working in Firefox (20 posts)

  1. janemar
    Member
    Posted 10 months ago #

    The font works in Chrome, iPhone, and Android. It worked in Firefox initially...seems to have broken when I went live. I haven't messed with the html or css, aside from a few style changes in the custom css field in Customizr. Thanks!

  2. rdellconsulting
    Member
    Posted 10 months ago #

    Link to site?

  3. janemar
    Member
    Posted 10 months ago #

    sethmargolis.com

  4. ElectricFeet
    Member
    Posted 10 months ago #

    I was just looking at your site trying to figure out what was going on and the social icons appeared on reload. Did you fix it somehow? What was it?

  5. janemar
    Member
    Posted 10 months ago #

    No, I haven't touched it, and I still don't see the icons. I cleared my cache, and I also checked on two other computers in my office and they also don't load them (they all display the code icons.

    The computers I've check on are all Macs. I'm running Firefox v 23.0.1

  6. rdellconsulting
    Member
    Posted 10 months ago #

    I still see the problem in Win7/Firefox.

    Did you try re-installing customizr in case it is corrupted somehow?

    Also disable plugins and see if anything changes.

  7. janemar
    Member
    Posted 10 months ago #

    I'll try disabling plugins first. I'm new at this, so it may take me a while to figure out how to reinstall the theme. Thanks for your support!

  8. rdellconsulting
    Member
    Posted 10 months ago #

    Just seen same issue on another post (different topic)
    http://www.irishcoffeechallenge.com/

    So will look forward to your result!

  9. janemar
    Member
    Posted 10 months ago #

    I deactivated two plugins I wasn't using: Contextly and Say What?. Worked! I check the site referenced above just to be sure the magic fix didn't happen in my browser, and it's still broken there.

    Thanks for the suggestion. Hope it helps other sites. You are all awesome!

  10. Dudo
    Member
    Posted 9 months ago #

    I've this problem too, but not only with firefox, but with all browser that I've: Firefox, Chromium, Opera.

    All plugins are deactivated.

    This problem suddenly appear after I changed my permalink structure (and removed .htacces file), and now on my workstation won't go away, even if i restored the .htacces file and permalink structure is the default one again.

    The strange thing is that I've always worked on child theme, and even if I try to use the parent theme this problem is still appear (yes, i flushed cache browser)

    On my laptop I've 1:1 copy of the website installed (file and database), and no problem in there.

    If I try from my workstation to connect to laptop i see everything fine, if from my laptop connect to workstation icons doesn't work.

    here is a screenshoot, any help is appreciatied!
    I apologize for my bad English,
    regards
    Dario

  11. Dudo
    Member
    Posted 9 months ago #

  12. Dudo
    Member
    Posted 9 months ago #

    sorry for this third pst.
    I just downloaded customizr again and overwrited the existing directory and everything get fixed.
    Surely I have edited some file from the parent theme unintentionally.

    Regards,
    Dario

  13. DonTimo
    Member
    Posted 9 months ago #

    How did you get it to work? Still have problems, icons are not displayed correctly.

  14. janemar
    Member
    Posted 9 months ago #

    The theme has been updated to fix this. So I downloaded and reinstalled installed the theme.

  15. DonTimo
    Member
    Posted 9 months ago #

    Okay, do you know what the theme authors changed or do you have contact information of them, so I can ask them?

  16. rdellconsulting
    Member
    Posted 9 months ago #

    The Forum is the best place to ask. Start a new Topic.

  17. rdellconsulting
    Member
    Posted 9 months ago #

    With a link to your site.

  18. DonTimo
    Member
    Posted 9 months ago #

    Just posted in here, because I thought that you might know what has to be changed in order to make these icons work, because you had the same problem! But it seems that you all updated your themes and their developers know what has to be changed ;)
    So I'm going to ask in Genericons board.

  19. DonTimo
    Member
    Posted 7 months ago #

    Just included the CSS and HTML code again, instead of using only CSS and now it works!

  20. OutdoorsWriter
    Member
    Posted 6 months ago #

    In Firefox, go to Tools, Options, Content. In Fonts & Colors, go to Advanced. Check "allow pages to choose their own fonts...." That took care of it for me.

Reply

You must log in to post.

About this Theme

About this Topic