WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics Dashboard
GDatainsufficientPermissionsUser Borked config (15 posts)

  1. T.McGuire
    Member
    Posted 1 year ago #

    How can I reset the config for the plugin? I'm getting the following error.

    Error gathering analytics data from Google: GDatainsufficientPermissionsUser does not have any Google Analytics account.

    This happened because I was logged into a Google account that didn't have analytic's associated with it when I tried to do the OAuth authentication.

    Now I can't find a way to reset the process.

    HELP!

    http://wordpress.org/extend/plugins/google-analytics-dashboard/

  2. arapacana
    Member
    Posted 1 year ago #

    Exact same problem here. I suspect I can laboriously go into the SQL database for wordpress, find the associated tables where this login info is stored by the plugin, and change it there, but there should be an easier way.

    I tried deactivating and deleting and then reinstalling the plugin but on activating the plugin did not go to the screen where it asked for authentication; it just gave the error immediately.

    Suggestions?

  3. T.McGuire
    Member
    Posted 1 year ago #

    My suggestion would be for the developer to post what we can search for in the database to 'forget' the login. OR even better, provide a button to reset the config of the plugin.

  4. vikkim
    Member
    Posted 1 year ago #

    Same problem here. Looking for a solution.
    Thank you.

  5. mhollman
    Member
    Posted 1 year ago #

    Also have the same issue.

  6. T.McGuire
    Member
    Posted 1 year ago #

    I used phpMyAdmin and did a search for gad_oauth_token which resulted in one entry. I deleted it.

    I then logged into Analytics and then hit the plugin settings page and was able to re-authenticate with analytics.

    Problem solved!...for me at least.

  7. pdlconsumption
    Member
    Posted 1 year ago #

    I used phpMyAdmin and did a search for gad_oauth_token which resulted in one entry. I deleted it.

    I then logged into Analytics and then hit the plugin settings page and was able to re-authenticate with analytics.

    Problem solved!...for me at least.

    @T.McGuire - Still working? Has anyone else tried this quick fix?

  8. T.McGuire
    Member
    Posted 1 year ago #

    Yes, the hack I did continues to be successful. The plugin is still working without any error.

    -T

  9. goatsontheroad
    Member
    Posted 1 year ago #

    T.McGuire, Please help.
    I've wanted this plugin for a long time but still getting that error. Went into PHPmyAdmin and just hit search gad_oauth_token but nothing happens. Am I supposed to search in a certain place? Sorry, new to the PHP side of things. Any help would be greatly appreciated

  10. T.McGuire
    Member
    Posted 1 year ago #

    Goats-on-the-road, Be sure to select your database from the list on the far left before doing a search.

  11. goatsontheroad
    Member
    Posted 1 year ago #

    T.McGuire, thanks for getting back to me.
    I had selected the database and then clicked search and pasted gad_oauth_token in, when i hit search it shows a blank area "show search criteria" with no results.
    Any Ideas?

  12. umair.razzaq
    Member
    Posted 11 months ago #

    Thanks T.McGuire. It works for me. I had same issue.

  13. Claverhouse
    Member
    Posted 11 months ago #

    Thanks. I was using Yoast's plugin for Google Analytics, and although going to the Google webpage showed all the information was being recorded, in my site I just had this error. Despite accepting the UA identifier in the plugin page.

    At first I thought it was due to the original javascript Google supplied from long ago still being in the footer, and thus double-reporting, but I eliminated that code, and the site continued to report data to Google whilst still giving the GDatainsufficientPermissionsUser error on the site...

    Yours was the only practical solution on the internet.

  14. Man2u2uk
    Member
    Posted 11 months ago #

    I'm having exactly the same issue but cannot find gad_oauth_token in any of my databases?

  15. sum1noc
    Member
    Posted 7 months ago #

    I spent hours searching online for a fix to this issue. I'm glad I came across this post and found a solution that fixed it. Thanks T.McGuire for providing the answer.

    I used phpMyAdmin and did a search for gad_oauth_token which resulted in one entry. I deleted it.

    I then logged into Analytics and then hit the plugin settings page and was able to re-authenticate with analytics.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.