WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
GD star rating plugin conflict with Better WP Security (8 posts)

  1. yanko_iliev
    Member
    Posted 1 year ago #

    When i have Better WP Security activated my GD star rating stars show only to logged in users... Please fix this bug. There are only 2 viable rating plugins for wordpress and GD Star is the better one. Thank you.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. vovafeldman
    Member
    Posted 1 year ago #

    Hi @yanko_iliev, are you familiar with the Rating-Widget plugin?

  3. yanko_iliev
    Member
    Posted 1 year ago #

    Hello and yes i am using it for my other site but this site i am making is fully responsive and when i tested the Rating widget on some devices it doesn't load :( Also GD star has good analytics and Rich snippets for free :) Anyway i am staying with Rating widget on my other site.

  4. vovafeldman
    Member
    Posted 1 year ago #

    Can you please share the url of the other site and what were the devices that didn't work? I'm the developer of the Rating-Widget plugin and it suppose to work on all devices, so if there is some problematic devices I would love to test and fix it. Thanks!

  5. yanko_iliev
    Member
    Posted 1 year ago #

    OK the site is Go2goldensands.com and the devices were Sony Experia Arc S and Samsung Galaxy tab but couldn't remember exactly which model it was.

  6. Helpful Guy Uk
    Member
    Posted 1 year ago #

    Hi,

    In Better WP Security you can disable the part conflicting with GD star Rating as follows:

    Login to you wordpress site then select "Security" option on the bottom of the left hand WordPress panel which will take you to Better WP Security options.

    Then select "Tweeks" from the Better WP Security options at the top of the page.

    Then scroll down and deselect "Display random version number to all non-administrative users" which is about third up from the bottom.

  7. turborock
    Member
    Posted 1 year ago #

    The option that fixed it for me was unticking "Prevent long URL strings" in betterwpsecurity.

  8. nikoza
    Member
    Posted 1 year ago #

    Hello all,

    the fix from Helpful Guy Uk worked great for me!!!
    It was driving me crazy!!!

    Thank you Helpful Guy Uk

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.