WordPress.org

Ready to get started?Download WordPress

Forums

garbled install.php in browser (20 posts)

  1. lefty
    Member
    Posted 8 years ago #

    Ok, I've been at this for about nine hours straight now, didn't want to come running here without having, at least, tried getting it working on my own.
    But if I don't get some help with this soon, my laptop is prolly gonna get a free ride out my window - woulnd't realy want that happening, since it's now very old...and I might end up hurting someone down on the sidewalk.

    I'll try to be as precise as I possibly can:

    My host is http://www.unoeuro.com, danish provider (i think). My database is already installed and they've provided me with a username and password, database name and so on (they list WordPress as one of the programs they have tested on their servers, so I should be in the clear there).

    (by the way: MySQL 4.0.18-standard-log running on localhost)
    ---

    the (zip) install file, has been unpacked correctly, with the folders and files and so on. Uploaded using SmartFtp to http://www.mysite.com/public_html/blog/ with everything CHMOD'ed as 777.

    the wp-config.php was fed all the info provided by my host (cut'n'paste) and uploaded into the "wp-admin" folder.

    ---

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'edotistic_com_db'); // The name of the database
    define

    ('DB_USER', 'edotistic_com'); // Your MySQL username
    define('DB_PASSWORD', '**************'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    .............[and so on]

    ---

    I'm using Opera (but have tried using Firefox and IE with same result), but cannot open the install.php file when in http - I am, however able to force it open via http://ftp...but that's when it's getting strange:

    ---

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $guessurl = str_replace('/wp-admin/install.php?step=2', '', 'http://' . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; ?>

    [Word Press Logo]

    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $wpdb->users"); if ($installed) die(__('

    [Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.]

    ')); $wpdb->show_errors(); switch($step) { case 0: ?>

    Welcome to WordPress installation. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. You may want to peruse the ReadMe documentation at your leisure.

    ---

    It then goes on to list step 1 and 2 (on the same page) with more garbled code.

    Since it's telling me that Word Press is already installed, I try going on to step 1 [.../wp-admin/install.php?step=1] but get a 404...in fact every link gives me a 404].

    ---

    As far as I can tell, there's nothing to indicate that it fails to contact my database - but I'm pretty sure that's where the problem is.

    The datebase is running just fine, but there are no tables created, neighter by me nor WP.

    If there would a helpful soul that could help me on a bit, I would be extremely thankful.

  2. vkaryl
    Member
    Posted 8 years ago #

    Guess this was a double post, huh? When you say "garbled code" what exactly is it? Could you post a (short) example?

    Have you tried dropping the database tables?

  3. lefty
    Member
    Posted 8 years ago #

    yeah, sorry about the double post - connection hickuped.

    The database claims there are no tables in it:
    [No tables found in database.]

    This is a bit of the code I'm getting:

    ---

    Second Step

    Now we’re going to create the database tables and fill them with some default data.
    query("UPDATE $wpdb->options SET option_value = '$weblog_title' WHERE option_name = 'blogname'"); $wpdb->query("UPDATE $wpdb->options SET option_value = '$admin_email' WHERE option_name = 'admin_email'"); // Now drop in some default links $wpdb->query("INSERT INTO $wpdb->linkcategories (cat_id, cat_name) VALUES (1, 'Blogroll')"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://blog.carthik.net/index.php', 'Carthik', 1, 'http://blog.carthik.net/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://blogs.linux.ie/xeer/', 'Donncha', 1, 'http://blogs.linux.ie/xeer/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://zengun.org/weblog/', 'Michel', 1, 'http://zengun.org/weblog/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://boren.nu/', 'Ryan', 1, 'http://boren.nu/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://photomatt.net/', 'Matt', 1, 'http://xml.photomatt.net/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES ('http://zed1.com/journalized/', 'Mike', 1, 'http://zed1.com/journalized/feed/');"); $wpdb->query("INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss).......

    ---

    It goes on, that's about a 4th of it, and then:

    ---

    Finished!

    Now you can log in with the login "admin" and password "".

    Note that password carefully! It is a random password that was generated just for you. If you lose it, you will have to delete the tables from the database yourself, and re-install WordPress. So to review:
    Login
    admin
    Password
    Login address
    wp-login.php

    Were you expecting more steps? Sorry to disappoint. All done! :)

    ---

    I'm not sure what the setup page is supposed to look like, but I'm guessing that I'm not supposed to see all the steps at once, on the same page.

  4. vkaryl
    Member
    Posted 8 years ago #

    Yeah, you're getting the actual code output. It's not garbled, it's just not supposed to display to you - it's supposed to run. There was a thread around here somewhere a while back about this that included a fix I think. Let me see if I can find a link - might take me a while searching, because I honestly don't remember what to search for!

    [Edit: Okay this is the thread I remembered. There's a post by podz that gives two possible reasons for this to be happening. The lady with the original problem never posted back with whether she got it fixed or not.

    Basically, here's the two possibilities:

    - you do not have PHP on the server. Who are you hosted with ?
    - you have incorrectly uploaded the file. What ftp client do you use?

    Check those out I guess, and let us know....]

  5. lefty
    Member
    Posted 8 years ago #

    I'm hosted with "www.unoeuro.com" their faq tells me that their using Linux Fedora for their PHP, doesn't say anything about Apache.

    I have access to phpmyadmin, but I have very limited possibilities; I can't create a new database (have to use the one that made for me) and messing around with the SQL is a big no-no.

    I can creat tables and so on, but would rather not, as my skills are very limited when it comes to databases i.e. I know what they do and how they work on a basic level...but that's about it.

    Just for the record; am I supposed to be able to activate WP by regular Http, or do I need to go through the Ftp to make it work?

    And, in phpmyadmin, do I need to kickstart the database in some way, or is it going to come to life when WP tries to activate?

    I'll try to upload the whole thing again.

  6. vkaryl
    Member
    Posted 8 years ago #

    You should be able to install WP by visiting http://www.yoursite.com/wordpress/wp-admin/install.php in your browser of choice. Shouldn't need to do anything besides upload with ftp.

    You might need to check versions etc. with your webhost.

  7. moshu
    Member
    Posted 8 years ago #

    You have to go through the installation process in your browser, by typing in the address line http://yoursite.com/wp-admin/install.php or with the proper directory name in between if it isn't in the root. You use the FTP ONLY to upload your files.
    If the data in your config file is correct WP will take care of the rest, i.e. it will create the tables and populate them with the necessary data.

  8. moshu
    Member
    Posted 8 years ago #

    ah, vkaryl types faster :)

  9. vkaryl
    Member
    Posted 8 years ago #

    Only sometimes, moshu!

  10. lefty
    Member
    Posted 8 years ago #

    yeah, ok, just as i figured - that's pretty much what I've been (trying) doing so far.

    But going through the folders via the browser only ends up giving me a 404...however, if I change the http:// to ftp:// I'm able to get in and execute the install.php .....but it gives me the extra raw code and pretty much does nothing.

  11. moshu
    Member
    Posted 8 years ago #

    But going through the folders via the browser only ends up giving me a 404...

    Which folders? What do you mean by "going through"?
    If 404 - you typing the wrong address.

  12. lefty
    Member
    Posted 8 years ago #

    hmmm, I just found something out. My host acctualy gives me one more piece of info, it tells me the name (adress) of the mysql server [mysql1.unoeuro.com] ...but sadly I'm at quite a loss as to how it can be useful.

  13. lefty
    Member
    Posted 8 years ago #

  14. moshu
    Member
    Posted 8 years ago #

    In your config file change this line:
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    to this
    define('DB_HOST', 'mysql1.unoeuro.com'); // 99% chance you won't need to change this value

  15. vkaryl
    Member
    Posted 8 years ago #

    What you need to put into the browser address bar is: http://mysite.com/blog/wp-admin/install.php (this is taken from your quasi link above - don't use the public_html part, that's part of the path used by ftp etc.)

    You shouldn't need to access any folders through ftp OR http. All you should need to do is type that line into the addy window, replacing mysite.com with whatever your site name actually is.

  16. lefty
    Member
    Posted 8 years ago #

    nope, sorry, still a 404...

  17. vkaryl
    Member
    Posted 8 years ago #

    Did you contact your host about versions and so on? Do you have a control panel of some sort? Sometimes a control panel will show you what versions they run for PHP, Apache, MySQL and so on; phpMyAdmin should show you the actual name of the database, just to double-check.

    And have you tried it both with and without "www." ahead of your site name, just in case your host's setup is wonky about it?

  18. lefty
    Member
    Posted 8 years ago #

    phpMyAdmin 2.6.2

    I can't find any trace of Apache, they state that their PHP servers run on Linux Fedora

    Managed to pick this out of their faq:

    <%
    SQLserveradr="mysql1.unoeuro.com"
    SQLdatabase="site_com_db"
    SQLlogin="site_com"
    SQLpassword="password"

    Set Conn = Server.CreateObject("ADODB.Connection")

    conStr = "driver={MySql};server="& SQLserveradr &";database="& SQLdatabase
    conStr = conStr & ";uid="& SQLlogin &";pwd="& SQLpassword & ";OPTION=3"

    Conn.Open conStr
    %>

  19. lefty
    Member
    Posted 8 years ago #

    hmmmm, the host support group finaly came up with an answer...turns out I didn't tick the PHP option when I signed up for the damned thing - now they want me to sign up a new one and yadda yadda yadda.

    Well, thanks anyways, you guys are princes among men - sorry to have wasted your time.

    Sayonara from Tokyo

  20. vkaryl
    Member
    Posted 8 years ago #

    Oh, that's too bad. Well, if you change hosts or plans and need more help, we'll be happy to oblige!

Topic Closed

This topic has been closed to new replies.

About this Topic