WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Garbage HTML in WordPress Posts (20 posts)

  1. pslager
    Member
    Posted 1 year ago #

    Hi,

    I have been suffering through this problem for the last 6 months and since I am stubborn it has taken me that long to ask for help.

    Anytime I try to publish a post to wordpress using MS Word 2010 as well as manually creating a post through the wordpress site. I get all of this HTML code instead of a properly formatted page. Here is an example http://paulslager.com/?p=1906

    Before this started happening this worked perfect. I am almost 100% positive this isnt a microsoft word issue though because I tried publishing from several different computers as well as using the new Paste from Word feature that wordpress has on the posts page.

    Here is an example of a page that worked fine before everything started screwing up http://paulslager.com/?p=1663

    I hope someone can help because even when I try to manually create a new post and not even Publish from Word I get all this nonsense HTML and the pictures don't show up.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  3. potentweb
    Member
    Posted 1 year ago #

    Use HTML mode instead of visual.

  4. pslager
    Member
    Posted 1 year ago #

    Thank you ESMI for your suggestions. I have tried 1-3 and it still is doing the same thing. I guess my next step is trying to re-upload all of the files..

  5. pslager
    Member
    Posted 1 year ago #

    Hi ESMI,

    Do I need to upload even the wp-login.php, index.php, etc?

  6. pslager
    Member
    Posted 1 year ago #

    Ug I dont know what is going on. I tried all 4 of your suggestions still getting the same issue. Any suggestions I am not a wordpress expert.

  7. pslager
    Member
    Posted 1 year ago #

    I can manually copy and paste the text from Microsoft Word into the post as HTML and it formats it correctly however using this method the pictures arent imported and I usually have a ton of pictures.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Don't paste content from Microsoft Word into WordPress as the pasted text will also contain Word's own formatting. Sooner or later, this formatting will stop your pages from being displayed correctly (if at all) in Internet Explorer. If you cannot possibly manage without Word, paste your text into NotePad (or another text editor) first, then copy from NotePad into WordPress.

    Or use Windows LiveWriter.

  9. pslager
    Member
    Posted 1 year ago #

    Well posting from Microsoft Word has worked for 5 years. Its not Microsoft Word that is messing up. Even if I manually go into WordPress clicks posts --> Create a new post using Visual, add images in the post and the formatting still has all the garbage HTML i referenced earlier, very freaking annoying. I need a way to publish the posts with Pictures very easily I cant be adding them 1 at a time thats ridiculous.

  10. pslager
    Member
    Posted 1 year ago #

    FYI I use Windows Live Writer 2011 maybe there is a newer version and I get the same issue.

  11. pslager
    Member
    Posted 1 year ago #

    This was published with Live Writer 2011 just a simple brand new test no copy and paste and I get all this garbage HTML!!

    http://paulslager.com/?p=1995&preview=true

  12. pslager
    Member
    Posted 1 year ago #

    Something very simple must have broke along the way. I already deactivted all plugins, used the default theme, updated wordpress, update and overwrote the wordpress files from a fresh wordpress 3.4 download via FTP.

  13. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    All your example links are 404 errors. Are they links to the dashboard?

    Can you post a link showing the problem?

  14. pslager
    Member
    Posted 1 year ago #

    Well that was stupid of me, I removed the posts ill publish as drafts so you can see again.

  15. pslager
    Member
    Posted 1 year ago #

    http://paulslager.com/?p=2000&preview=true

    Here is one I uploaded with Live Writer 2011

  16. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I can't see a draft as that is on the backside of wp.

  17. pslager
    Member
    Posted 1 year ago #

  18. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I have the same results with live writer. I am still looking into it.

    Possible help here, http://social.microsoft.com/Forums/en-US/writergeneral/threads/
    and here http://answers.microsoft.com/en-us/windowslive/forum/writer?auth=1

    Copying the source from lw and pasting into wp html works except for photos which have a url problem.

  19. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  20. pslager
    Member
    Posted 1 year ago #

    Dude you are a genius seriously!

    The blog post fixed it I had to install this plugin LibXML2, and now I can publish with Microsoft Word and Live Writer again without any issues!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.