WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
"Garbage collection interval" ignored--pages cached too often (4 posts)

  1. jumbo
    Member
    Posted 1 year ago #

    In the page caching options I have "Garbage collection interval" set to 86400 seconds (1 day), but it looks like W3TC is re-caching these pages about every 30 minutes or 1 hour. These pages are hardly updated, so I don't need them cached so often.

    Is there any way to make this work as expected? I suspect this has to do with "Cache Preload > Update interval" being set to 900 seconds (the default setting), but even so, why is the garbage collection interval ignored?

    Do I need to update the cache preload to 86400 seconds to make it work correctly? I have "Automatically prime the page cache" checked and my XML sitemap specified, but this occurs even if prime the page cache is unchecked.

    BTW, I'd rather use "enhanced" disk caching, which doesn't have this problem, but I need to use "basic" disk caching in order for my redirects to work.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. jumbo
    Member
    Posted 1 year ago #

    Quick update: I tried changing "Preload Cache" from 900 second (15 minutes) to 21600 (6 hours), but it didn't make a difference--my pages keep getting rebuild every 15-30 minutes.

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have this issue when using latest version as well? If so, please submit a bug submission form from the support tab of the plugin.

  4. jumbo
    Member
    Posted 1 year ago #

    Hi Frederick. I'm still on v0.9.2.4 and have since switched back to enhanced caching. I've got that set to garbage collect every 86400 seconds, but for some reason it gets reset about every 12 hours. Other than that it seems to work pretty good.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic