WordPress.org

Ready to get started?Download WordPress

Forums

Gap between top of page and element for Toolbox theme (6 posts)

  1. Joshua Mohan
    Member
    Posted 2 years ago #

    I'm using a child theme based on the Toolbox theme and I'm seeing a weird gap between the top of the page and the <body> tag.

    I know the problem is being caused by the get_header() function, because when I comment that function out the problem disappears. However, I have no clue where in the header this is being caused.

    The trick is, from what I can tell, this is not an issue with CSS! I've set the margins, padding and border all to 0 for html and body. I've tried messing with positioning and nothing.

    In Chrome, I can look at the underlying structure and I see nothing in the CSS or DOM that is causing this gap.

    Here is a screencap of me highlighting the html element:
    http://postimage.org/image/rfj55eg2x/

    Here is a screencap of me highlighting the body element:
    http://postimage.org/image/ga5dhx3o5/

    I can't see anything in the CSS that is causing this, which is causing me to rip my hair out!

  2. Joshua Mohan
    Member
    Posted 2 years ago #

    Found the problem.

    The styling on the h1 tag had a margin-top that was pushing everything down from the top of the page.

    Screencap:

    http://postimage.org/image/h2v5ci547/

  3. awkh88
    Member
    Posted 2 years ago #

    Hey Josh,

    Here is a silly question, but where is the .css file that sets the defaults for h1 etc...? I can't find it, so i can't get rid of that white bar!!

    Regards,
    Andreas

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Try using Firefox with the Firebug add-on for this kind of CSS work.
    http://getfirebug.com/

  5. awkh88
    Member
    Posted 2 years ago #

    Great! Thank you very much!

  6. pcland
    Member
    Posted 2 years ago #

    thanks!! i didn't think to check that.

Topic Closed

This topic has been closed to new replies.

About this Topic