WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Galley problems since 3.5 (5 posts)

  1. Schrijfmeisje.nl
    Member
    Posted 1 year ago #

    I updated to 3.5 last week and my galleries don't work properly anymore ever since. Before, I used the Lightbox Gallery plugin. However, when I insert a gallery and click on a picture on my website, I get a messed-up frame without a picture in it instead of an enlarged picture like it's supposed to show. When I deactivate the plugin and click one of the gallery pictures, I am redirected to a new page where the picture is shown.

    I would very much love to be able to view the pictures like I used to with Lightbox Gallery, but I have no idea how to solve this. Right now, the plugin is still deactivated because being redirected is a better option than a messed-up frame without picture, but I'm hoping someone can help me out. I've already Googled the problem and browsed through the forums, but haven't found a solution.

  2. deepbevel
    Member
    Posted 1 year ago #

    You may find that the quickest way to solve it is to try another lightbox plugin. I know easy fancybox still works in 3.5.

  3. vincej
    Member
    Posted 1 year ago #

    Not sure if it helps in your case, but the new galleries in wp 3.5 seem to generate different code.

    When you insert a gallery now, it reads something like.

    [gallery ids="411737,411733,411736,411735,411732,411734"]

    Change this to
    [gallery ids="411737,411733,411736,411735,411732,411734" link="file"]
    or just
    [gallery link="file"] and lightboxes should work again.

    I'm rather displeased with the new gallery implementations altogether, though.

    IN my case i'm using auto thickbox, and jquery lightbox for my site, works with above change.

    cheers, hope it helps.

  4. Schrijfmeisje.nl
    Member
    Posted 1 year ago #

    @vincej: Unfortunately that didn't do the trick, but thanks for your reply!
    @deepbevel: I installed Easy Fancybox and the problem is solved. I even like the looks of this plugin better, haha. Thanks for your help!

  5. deepbevel
    Member
    Posted 1 year ago #

    one of the first plugins I ever used, always reliable and fairly flexible. I have it on many sites, many themes..glad it helped.

Topic Closed

This topic has been closed to new replies.

About this Topic