WordPress.org

Ready to get started?Download WordPress

Forums

[Gallery] shortcode column problem... (3 posts)

  1. nast0
    Member
    Posted 5 years ago #

    Right, I'm at my wits end :)

    I've been trying to post images using the new [gallery] shortcode into my blog. When I first tried this I noticed all the images appeared in 1 column... so I read up on some docs, and added the columns="3" parameter to the shortcode. Bad news is, it didn't do anything.

    Regardless of what I try I can't get 3 columns to appear, I've saved, re-sorted, edited, re-saved, read every doc, and even checked the code in media.php for errors. They won't appear in 3 columns.

    I can't find anyone with a similar problem, and don't have sufficient kmowledge of WP to figure this one out.

    Can anyone tell me;

    Does your template have any bearing on how a [gallery] is displayed? (I'm using Decayed).

    Is there any way to override the default columns of 1, with 3? (I've seen the code snippet in media.php on line 384)

    Any other idea what could be doing it?

    Thanks in advance,
    n

  2. jrgd
    Member
    Posted 5 years ago #

    i have the exact same problem - can't manage to fix it... driving me slightly insane

    any news on this?

  3. t31os
    Member
    Posted 5 years ago #

    A link to both your sites, preferably to pages that have [gallery] inserted images might be a good place to start...

    Sounds to me like you need to add the CSS for the gallery elements...

    Since not everyone uses the [gallery] functionality the necessary classes are not written in the stylesheet as standard..

Topic Closed

This topic has been closed to new replies.

About this Topic