WordPress.org

Ready to get started?Download WordPress

Forums

Hatch
Gallery Problem with Hatch (19 posts)

  1. gjsouthwell
    Member
    Posted 1 year ago #

    Hi,

    I've inserted a gallery, using files from the media library. However, when I add new files to the library, or upload them straight into the gallery, they seem to overwrite the previous files. Actually, when you look at the html, the previous images are there, but just don't display. If you remove the uploaded files from the gallery, then the previous images display fine.

    Any suggestions? I've narrowed the problem down to Hatch - the gallery displays fine with other themes.

    Thanks.

    Gareth.

  2. amire
    Member
    Posted 11 months ago #

    I am experiencing exactly the same problem.
    Gareth did you manage to resolve this?
    Anyone else able to help?

  3. gjsouthwell
    Member
    Posted 11 months ago #

    Hi Amire,

    No, sorry. In the end, I gave up and installed a different template. Frustrating!

    Gareth.

  4. paulwpxp
    Font hero
    Posted 11 months ago #

    What WP version ? and Hatch version ?

    Better yet if you could provide a link to the page/post in question so someones here can help figuring out what might be the problem.

  5. amire
    Member
    Posted 11 months ago #

    Thanks for responding.
    Wordpress 3.5.2. Hatch up to date latest version
    Website http://www.paulaelion.com though not sure how it can help as this happens on admin editing galleries in post not on front end.

  6. paulwpxp
    Font hero
    Posted 11 months ago #

    Not sure if related, but worth mentioning.

    Jetpack installed, but image URLs link to normal WP upload folder as opposed to Jetpack CDN with Photon module on by default. Please note that this is just an observation, not encouraging you to enable it if disabled with intention.

    WP injected gallery CSS inside the page normally along with the <br> thing instead of getting cleaned up by Cleaner Gallery extension included by Hatch theme.

    Also, you mentioned that this happen in admin only, since WP media workflow is done using JS, might as well involved web browser vendor and version too.

    If not already yet, please consider trying these.

    • Try performing the same task with different browser, ideally Chrome or Firefox.
    • Temporary disable all plugins, and try.
    • With all plugins still disabled, switch to default theme (TwentyTwelve).

    During the test, don't forget to clear browser cache (hitting Ctrl+F5 a few times), otherwise the result would be just cached version.

  7. amire
    Member
    Posted 11 months ago #

    @paulwpxp
    When I switch to theme Twenty thirteen all the images show up on the gallery, with all the added/removed. It doesn't even require clearing any cachaes.
    When I switch back to Hatch, they disappear again.
    Could Hatch perhaps only show images that were added after the post was updated?
    I am using Chrome, BTW

  8. amire
    Member
    Posted 11 months ago #

    Also - still happens with all plugins deactivated.
    And also - all the images are shown on the post text editor, e.g.:
    [gallery columns="6" link="file" ids="275,253,252,248,245,241,239,237,228,213,518,519,520,521,522"]
    but only the latest 5 uploaded end showing up.

  9. paulwpxp
    Font hero
    Posted 11 months ago #

    Your last post leads to the possibility that it's the Cleaner Gallery (one of the extentions in Hybrid Framework) used in Hatch theme that's not updated to WP3.5 gallery yet.

    Plugin version: see the ids argument (new in WP3.5 gallery)
    http://plugins.trac.wordpress.org/browser/cleaner-gallery/tags/0.9.3/gallery.php#L56

    Hatch version: see there is no ids argument yet.
    http://themes.trac.wordpress.org/browser/hatch/0.2.6/library/extensions/cleaner-gallery.php#L56

  10. paulwpxp
    Font hero
    Posted 11 months ago #

    It's related to how you use image in WP too, if you have a habit of uploading images directly to post/page only, you could just use this

    [gallery columns="6" link="file"]

    To make a gallery show images not necessary in that post/page, use include option.

    [gallery columns="6" link="file" include="275,253,252,248,245,241,239,237,228,213,518,519,520,521,522"]
  11. amire
    Member
    Posted 11 months ago #

    Thanks for the reply.
    From your answer it's not clear to me if there a fix I might use or I have to wait for the code update in the Cleaner gallery/Hatch theme?

  12. paulwpxp
    Font hero
    Posted 11 months ago #

    So far, it indidates that the not updated version of Cleaner Gallery in Hatch is causing the problem, but to rule it out for sure you have to try disable this extension in Hatch. To do so you have to be comfortable with editing code on a live site and know what to do when things go wrong. If not, it's better to wait for the update or contact the theme author reporting the issue (use the contact form in his website).

    Also, it's nothing to lose to try the last code I provided.

  13. amire
    Member
    Posted 11 months ago #

    Just want to make sure the best route to fix.
    I haven't done any WP development, and just want to find a fix I can handle.
    Should I try to make a childe theme of hatch and replace the existing cleaner gallery code with the updated version?
    I think I can handle that.
    Your help appreciated.

  14. paulwpxp
    Font hero
    Posted 11 months ago #

    Have you tried the last code I provided see if that works ?

    Have you contacted theme author via his contact form ?

  15. amire
    Member
    Posted 11 months ago #

    I contacted the theme author - no response so far.
    I was not sure I am supposed to change:

    Just use this:
    [gallery columns="6" link="file"]

    Instead of:
    [gallery columns="6" link="file" include="275,253,252,248,245,241,239,237,228,213,518,519,520,521,522"]

    or merge the clear gallery code fixes?

  16. amire
    Member
    Posted 11 months ago #

    I just replaced the outdated clear gallery code with the old one in Htach in this seems to have fixed the issue.
    Looking good so far,
    Thanks!

  17. paulwpxp
    Font hero
    Posted 11 months ago #

    The first code will pull into the gallery all images attached to that post/page ( in other words, all images that were directly uploaded to that post/page ).

    The Second code will pull images with that id(s) regardless of post/page they are attached to.

    Try using the second code to whatever post/page that you originally took this code from
    http://wordpress.org/support/topic/gallery-problem-with-hatch?replies=15#post-4491494

    EDIT: I posted this 8 seconds after yours above.

  18. Aya
    Member
    Posted 11 months ago #

    Hi Amire,

    How did you go about replacing the outdated Cleaner gallery code? Any help would be appreciated!

    Thanks,

    Aya

  19. amire
    Member
    Posted 11 months ago #

    Hi Aya,
    As suggested by paulwpxp, this is what I did:
    I took the latest cleaner gallery code from here:
    http://plugins.trac.wordpress.org/browser/cleaner-gallery/tags/0.9.3/gallery.php

    and placed it instead of the exiting code under the Hatch theme here:
    library/extensions/cleaner-gallery.php

    (using the cleaner-gallery.php file name)

    That's it. That did the trick.
    Make sure you take all the regular persuasions e.g. backup etc.

    Good luck,
    Amir

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic