WordPress.org

Ready to get started?Download WordPress

Forums

Gallery permalinks generating 404 errors (4 posts)

  1. rklau
    Member
    Posted 6 years ago #

    Hi -

    I have a working install of 2.5 on my site, and used the media manager for the first time last night. On the most recent post, I uploaded three pictures of our new dog. The [gallery] code works great and generates the thumbnails in the post.

    The problem is the permalinks to the images. One image is here:

    http://www.rklau.com/tins/wp-content/uploads/2008/04/dsc_0058.jpg

    But WP's Gallery is converting that to:

    http://www.rklau.com/tins/archives/2008/04/05/welcome-to-cody.php/dsc-0058/

    The first URL works, the second (which is what's in the post) is generating a 404 error.

    Any ideas how to correct this so clicks from the gallery resolve to the image permalink?

    Thanks.

  2. haochi
    Member
    Posted 6 years ago #

    LOL, I just read your post about your new dog in Google Reader this morning!

    Well, it's probably because of the .php at the end of the URL causing this, so you might want to remove that (temporary) in your settings and see if it works.

  3. rklau
    Member
    Posted 6 years ago #

    Haochi -

    That's pretty funny. Small world!

    Removing the .php in the permalinks settings didn't help; same result.

  4. BJ05
    Member
    Posted 6 years ago #

    2.5 is worthless!

    Clicking on options to some of my plugins, such as NextGen, Polls, Wassup and Statpress result in 404 redirects

Topic Closed

This topic has been closed to new replies.

About this Topic