WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Gallery no longer showing (9 posts)

  1. karenlea
    Member
    Posted 11 months ago #

    The Gallery was all working fine but now it is just not showing at the front end: http://www.octaviasbookshop.co.uk/events/photo-gallery/

    Theme Multidesign
    You are using WordPress 3.6.
    NextGen Gallery Version 2.0.17

    It all looks set up correctly, but I've no idea what is wrong. Can someone help?

    PLUGIN CHECK:
    All green ticks

    SERVER SETTINGS:

    Operating System : Linux (64 Bit)
    Server : Apache/2.2.8 (Ubuntu) mod_ssl/2.2.8 OpenSSL/0.9.8g
    Memory usage : 45.76 MByte
    MYSQL Version : 5.0.51a-3ubuntu5.5
    SQL Mode : Not set
    PHP Version : 5.2.12-0.dotdeb.0
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 128
    PHP Max Upload Size : 2M
    PHP Max Post Size : 8M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : Yes
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : Yes
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    Thanks
    Karen

    http://wordpress.org/plugins/nextgen-gallery/

  2. andrijaf
    Member
    Posted 11 months ago #

    Have the same problem:

    http://unique-sportstime.de/site/laufbilder/frankfurt-marathon-galerie/

    Backend seems to have no problems

  3. karenlea
    Member
    Posted 11 months ago #

    I have made a new page to test it, as I noticed I might be using old shortcodes in the original page. So the new page is:
    http://www.octaviasbookshop.co.uk/events/gallery/

    I used this shortcode: [ ngg_images gallery_ids="1" display_type="photocrati-nextgen_basic_thumbnails" ]
    (minus the spaces in the brackets).

    If I leave in gallery_id=1, I get a message on the front end "no images were found" which I would expect as I don't have a gallery with this ID.

    If I change the ID to 2, which I do have images for, the page just goes blank.

    Anyone know what is up?

    Karen

  4. karenlea
    Member
    Posted 11 months ago #

    I tried to make it show an album instead, using this code:

    and now got this error:
    [album id=1 template=compact]

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 122880 bytes) in /home/o/c/octaviabooks/web/public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/adapter.nextgen_basic_thumbnails_controller.php on line 141

  5. andrijaf
    Member
    Posted 11 months ago #

    Hey karenlea,

    I saw you got it working :) almost. What was the solution? or do you consider it a solution?

    best regards

  6. karenlea
    Member
    Posted 11 months ago #

    Hi

    I got our hosts to increased our PHP memory limit.

    The error you saw was a test gallery. I've deleted it and now it is all OK.

    This is the code I've used:

    Check out our lovely gallery of photos from our many events.
    Thanks to all the wonderful authors and friends that join us to make it all worthwhile.

    Book Signings
    [nggallery id=2]

    Opening Day
    [nggallery id=3]

    Phew. Back to designing for me now.

  7. andrijaf
    Member
    Posted 11 months ago #

    Im my case I get:

    Fatal error: Call to a member function display_images() on a non-object in /var/www/vhosts/unique-sportstime.de/httpdocs/site/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/module.nextgen_basic_gallery.php on line 164

    I guess this isn't a memory issue :(

  8. andrijaf
    Member
    Posted 11 months ago #

    I think it is a PHP 5.3 issue. I had to downgrade the plugin like this:

    • Download Version 1.9.13 here
    • Unzip
    • Deactivate Nextgen Gallery in WordPress-Admin
    • Delete dir wp-content/plugins/nextgen-gallery on server
    • Upload the previously unziped folder to wp-content/plugins/
    • Activate the plugin in WordPress-Admin
  9. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @karenlea - Thanks for the information and the feedback on this issue as well as the solution you were able to find. This type of information is always great to share with the community.

    @andrijaf - That is unfortunate you had to revert to the legacy version but can you share how you were able to point to your issue being one related to PHP 5.3? This would be very helpful.

    Thanks!

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic