WordPress.org

Ready to get started?Download WordPress

Forums

gallery media file link not working as default (9 posts)

  1. iadagraca
    Member
    Posted 1 year ago #

    This issue has been rather annoying to my users.

    when making a gallery the default setting of linking to "media file" does not work. you have to set it to attachment page then set it back to media file, and its often easy to forget. once submitted it goes not only to our site but other sites like tumblr with the attachment page instead of the image.

    Is this a known bug or can i fix this?

  2. pealo86
    Member
    Posted 1 year ago #

    Same problem here, could do with this fixing!

  3. evster
    Member
    Posted 1 year ago #

    Getting the same bug here!

    WordPress 3.5.1

    The fix seems to be setting the gallery to "attachment page" and then back to "media file" as suggested in the first post.

  4. abdessamad idrissi
    Member
    Posted 1 year ago #

    This a bug in WordPress js not generating the file attribute. it's on trac http://core.trac.wordpress.org/ticket/23298

    Hopefully it gets fixed on 3.5.2

  5. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    This bug should be fixed in the next WordPress update but, for now, you have two options that might work:

    1. If you have been using the Text editor to edit your Posts & Pages then locate the [gallery] shortcode and amend it to [gallery link="file"]

    2. Try editing the relevant Posts/Pages and creating the galleries again but, this time, toggle the "Link To" dropdown from Media File to Attachment page" and back again.

  6. Gouri
    Member
    Posted 1 year ago #

    Wow esmi, supercool. Using the first option... working great. Thanks a lot.

  7. erikdana
    Member
    Posted 12 months ago #

    any other fix to force link to media file as default?

  8. Media X
    Member
    Posted 11 months ago #

    @erikdana: Gallery is by default linked to media files BUT when you insert the gallery the shortcode doesn't format properly (doesn't add link="file") so you have to go back and forth between Media File & Attachment page.Afterwards the shortcode gets updated and works just as it should.
    Side note: untill the WP update fixes it, i don't mind toggling between the two options to get it working but my client does :P Maybe i should make "Attachment page" the default then he should toggle only once?

  9. Dean Oakley
    Member
    Posted 11 months ago #

    Try the cleaner gallery plugin. In the settings you can select the image file as the link and it works.

    http://wordpress.org/extend/plugins/cleaner-gallery/

Topic Closed

This topic has been closed to new replies.

About this Topic