WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Galleries won't show up in adminpanel..? (4 posts)

  1. Thomas
    Member
    Posted 1 year ago #

    I'm trying to create new galleries on a clients website but they won't show up in the adminpanel or on the site. They are created on the ftp so "it works" but then again no..

    Any ideas?!
    Using NextGen 1.9.6, i've tried to disable the plugin and enable it again. I've tried disabling other plugins on the site, but nothing seems to help.. :|

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smigliorato
    Member
    Posted 1 year ago #

    Are you uploading the images via ftp?

    If you do that, you still need to go to Gallery->Add Gallery/Images and click on import image folder. The default setting assumes galleries are placed in a folder in wp-content/gallery/.

    You can either move the folder there and import (makes it simple to have your galleries in that folder), or go to Gallery->Options and the set the first option "Gallery Path" to the folder where you want your gallery folders to go.

  3. Thomas
    Member
    Posted 1 year ago #

    I'm trying to upload from within NextGen itself..
    Creating the gallery, naming it, but when i try to upload images to the gallery, the gallery don't exist att all in NextGen.

    When i look in the ftp though, the newly created galley/folder is there.
    The settings are correct (wp-content/galley/) and it has been working just fine for about a year.

  4. smigliorato
    Member
    Posted 1 year ago #

    Based on another thread, this could be a filesystem permissions issue.

    Maybe you have write access, but not read access?

    Use your ftp client and try to check the permissions of the gallery folder.

    This can also be affected based on who "owns" the folder. There are three classes of permissions:

    Owner
    Group
    Public

    Public shouldn't be able to write period. Read and execute is (usually) fine.

    The owner is usually the one who created the file. The group (by default) should refer to other members of groups the owner belongs to.

    Does the owner and/or group have write but not read access?

    With just FTP, you can't change owners/groups etc (that I know of), but you can change permissions (Check your FTP software documentation). I use Filezilla, and you just right click and select permissions.

    You will have to contact your host about the details. Some hosts will allow shell/SSH access (bascially, command line access to your server) so you could use chown or chgrp to change owners and groups on files. You will have to find out what user your server/wordpress is running on, etc.

    Basically, it is pretty dependent on server setup what exactly you would need to do to fix it if this is the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.