WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
G analytics says "Tracking Not Installed" but it is... (4 posts)

  1. spikyman
    Member
    Posted 1 year ago #

    Hi! Just installed your nifty product, but....

    On any page, I can see where All in One SEO has installed what Google help docs now calls the "traditional tracking code snippet." (Which is recommended "If you have not yet migrated to the asynchronous version of the tracking code snippet.")

    It also correctly shows my Property ID: UA-42345102-1, and Default URL: http://timokane.com

    It is NOT, however, the code that Google recommends using on the Website Tracking page in my account (pasted below).

    ???

    Thanks,
    Mark

    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-42345102-1', 'timokane.com');
    ga('send', 'pageview');

    </script>

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Mark,

    Yes, Google has updated this somewhat, and we are following what they have been doing here, and will update accordingly; but more importantly, I see you also have Google Analytics tracking in your footer. You'll want to remove this, you should only have Google Analytics tracking code appearing once per page.

  3. bmsinc
    Member
    Posted 11 months ago #

    quotes are not escaping in the analytics code when I put it into the additional header sections. Im running all in one SEO 2.0.2 - see below

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    
      ga('create', 'UA-40939789-1', 'kathyljacobson.com');
      ga('send', 'pageview');
    
    </script>

    do we have an ETA when there will be an update rolled out to address this?

  4. bmsinc
    Member
    Posted 11 months ago #

    errrr...when i pasted the code in, it did add the '' in the proper spots

    let me try this again

    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    
      ga('create', 'UA-40939789-1', 'kathyljacobson.com');
      ga('send', 'pageview');

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic