WordPress.org

Ready to get started?Download WordPress

Forums

Funny characters after server move:  (27 posts)

  1. PKYI
    Member
    Posted 7 years ago #

    I am seeing funny characters after a server move:  .

    Those characters tend to show up after periods.

    Can anyone tell me what I'm doing wrong?

    Using version 2.2.

  2. jamespoling
    Member
    Posted 7 years ago #

    join the crowd. The exact same thing happened to me. I have a thread started here: http://wordpress.org/support/topic/120562?replies=3

    I used phpMyAdmin to export and import the DB. I tried adding the charset code to the wp-db.php file and a couple of other files I found on here, but there doesn't seem to be one solid solution.

    This seems to be a very odd problem and even more frustrating that there doesn't seem to be an easy solution.

    I am also using 2.2.

    I am currently having someone try to export/import the database using SSH to see if the same problem happens. If it does then this seems like a pretty major issue that needs to be fixed.

  3. MichaelH
    Member
    Posted 7 years ago #

    Please, could you post your complete wp-config-php file to http://wordpress.pastebin.ca/ and report the link back here.

    Is that the same wp-config.php you used for both the old and new host? If not please post both versions if you can.

    Can you describe the export for the old database and the import to the new database procedure you followed?

    What did you use to create the new database?

  4. jamespoling
    Member
    Posted 7 years ago #

    NEW: http://wordpress.pastebin.ca/538910

    OLD: http://wordpress.pastebin.ca/538928

    I just realized I didn't add the charset code to the old one, although I am sure at one point I did. I've been trying it for days.

  5. moshu
    Member
    Posted 7 years ago #

    Actually that's the point: in the old config file you didn't need the charset (and collation) line and when upgrading your WP you should NOT add those!

  6. moshu
    Member
    Posted 7 years ago #

    @PKYI,
    Are you from the the old school (=paper + typewriter) and hitting the space TWICE after a period? Don't do it! This is a different medium with different rules.

  7. jamespoling
    Member
    Posted 7 years ago #

    I'm not upgrading, I'm migrating, and the characters here there whether or not I added that to the wp-config.php file or not. That's why I added it to the new one because it did happen in the first place.

    Also, is that true? I always use two spaces after a period. And yes I did learn that back from typewriter days. Damn, I'm still doing it.

  8. PKYI
    Member
    Posted 7 years ago #

    OLD
    ---
    // ** MySQL settings ** //
    define('DB_NAME', 'beave8_wrdp1'); // The name of the database
    define('DB_USER', 'beave8_wrdp1'); // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    NEW
    ---
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'umill3_wrdp1'); // The name of the database
    define('DB_USER', 'umill3_wrdp1'); // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    I downloaded old sql via Php myadmin. EXCEPT for the options table.

    Then I installed a fresh install of ver. 2.2 on my new server. Then I went into php myadmin and clicked on SQL tab, and inserted the SQL queries of old database into the box. and hit enter.

    Hope this helps.

    I would delete those weird symbols manually, but I have a LOT of entries.

    @moshu, Yes, I think I use double tab, double space a lot. :(

  9. moshu
    Member
    Posted 7 years ago #

    Ah, with migrating it is always a mess - but that's a MySQL issue. Even this forum got screwed up more than a year ago when the devs moved it to another server with a different MySQL version. You can find older posts with "funny characters".

    It's getting late here and I can't remember where did I see some notes about migration. Where the two MySQL databases of the same version?

  10. moshu
    Member
    Posted 7 years ago #

    PKYI,
    you didn't mention till now it was a move.
    (I hope those passwords were not real - anyway, I deleted them!)
    No, you don't need the two lines about charset and collation. Delete them!
    Those lines are for brand new installations not upgrades and/or moved blogs.

  11. jamespoling
    Member
    Posted 7 years ago #

    Moshu, you keep saying we don't need those two lines but the only reason, at least for me those lines were added was because I had the issue originally without the two lines.

  12. BigBri
    Member
    Posted 7 years ago #

  13. jamideleon
    Member
    Posted 7 years ago #

    I have the same problem because of the upgrade to WP 2.2, if I remove the two lines in wp-config.php will it remove all the Â's automatically or I still need to remove them manually?

  14. manfredeye
    Member
    Posted 7 years ago #

    Â Â Â - I too am having trouble figuring out how to change my new upgrade to stop those annoying symbols. I was just advised to upgrade to 2.2, then found that I need to now upgrade to 2.2.1?
    I use fantastico thru my webhost and am having a bit of trouble with exactly what to do to fix this bug.
    thank you for any advice.

  15. lockwood77
    Member
    Posted 7 years ago #

    Deleting the two lines:

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Did the trick for me when upgrading using Fantastico.

  16. Jonno99
    Member
    Posted 7 years ago #

    I deleted the two lines, and it got rid of the  characters, but now there are some (not as many) question mark ??? characters where the  used to be.

    Any ideas on this one?

  17. zern
    Member
    Posted 6 years ago #

    I have had this issue twice - when migrating to 2.2, and then to 2.2.1. Both upgrades via Fantastico.

    My fix is this:
    - Comment out the 'DB_CHARSET' and 'DB_COLLATE' lines.
    - Go to Options/Permalinks and re-save that page. (otherwise the links to posts break).

    Hope this helps someone.

  18. Successenroute
    Member
    Posted 6 years ago #

    i did no migration nor upgrading of my wordpress ver 2.1.3 but it still have the same weird characters appearing thru out my blogposts, any solution? This only happen about a month plus ago till now.

  19. Successenroute
    Member
    Posted 6 years ago #

    halo, why no one reply to me??? Is this the wordpress support or not??? where is the support guys???

  20. Hanenwurger
    Member
    Posted 6 years ago #

    This issue is disgrace, sorry. But your post seemed to be the solution, Zern.

    Thanks.

  21. Opally
    Member
    Posted 6 years ago #

    This is not a solution when there have been new entries after the upgrade. Making the suggested change to wp-config.php turns all the new curly quotes into garbage.

    Right now it looks like I have to manually edit each entry -- more agony because there is no search/replace utility in the editor, means copying and pasting into another editor and back again... ugh.

    If anyone has any more information to share, I'd like to hear it.

  22. RuedAuseil
    Member
    Posted 6 years ago #

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Thanks this worked after over a year of giving up. Zern and that person who helped people even though "been here a day and you [dare]..."

    This old school bigotry excuse for ineptitude was irresponsible enough and hate crime intensive enough to make me think seriously think of suing this group of arrogant little vipers.

    How Dare You screw with people's lives and pretend you know how to develop. This A character thing was always your screw-up. No two spaces? Tell that to Ezra Pound and 100s of other poets if Code is Poetry.

    This "space" needs to be investigated, if the culpable kids' parents will testify.

    Thank God for people like the First Day Helper and Zern.
    Probably others who tried to help me resolve this tech puerile SCREW UP for over a year.

    Shame. It is about incompetence, cowardess, hubris, and shame.

    I DEMAND that a moderator of this group of threads call me and explain why litigation should not commence!

    You have neither the license nor the capabilities to play with the Big Boys of any nominal age!

  23. arnoldstewart
    Member
    Posted 6 years ago #

    This does need fixing. I've just changed hosting services and now the blog is full of little squares. Editing them out doesn't work so I think they might be related to the visible space character or similar but I can't find any way to remove them.

  24. carpii
    Member
    Posted 6 years ago #

    Ive just spent several hours looking into this, not to do with wordpress, but a problem on my own site whereby restoring a mysql backup wasnt preserving the utf8 encoding

    {or so it seemed}

    In actual fact, the backup was restoring fine, and the data was being preserved. But my new server had a different php ini setting for the default charset.

    Try this is youre having problems, who knows, it might just work. First of all try changing the charset in your browser, if youre using firefox, try forcing it to use utf8, rather than autodetect.

    If this fixes the problem, you should edit your php.ini to explicitly set the default charset to be utf-8.
    Hey presto, no more nasty ÂÂ

  25. sannie7
    Member
    Posted 6 years ago #

    those two lines

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    were not present in my wp-config.php.
    therefore, the  are still there.

    what do i do?

  26. Mike Rouse
    Member
    Posted 6 years ago #

    Has there been any definitive fix for this? Is there a plugin that will carry out the necessary conversions?

  27. Mike Rouse
    Member
    Posted 6 years ago #

    Even though it's only been a few minutes I've been able to find a plugin that worked for me. Here it is:

    http://wordpress.org/extend/plugins/wp-utf8-sanitize/#post-2363

    It got rid of nearly all the funny characters. Just a few to manually remove deep down in the archive for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags