WordPress.org

Ready to get started?Download WordPress

Forums

CRM Integrator
[resolved] functions.php file messed up in Zoho CRM Integrator section (2 posts)

  1. Judge-Mentals
    Member
    Posted 11 months ago #

    Hello, have been running the plugin without issue but suddenly it looks like there was some code accidentally deleted from the functions.php file, causing my site to crash

    Removing the code completely that was to do with Zoho CRM Integrator plugin has fixed the problem to an extent (the site is up and running) but I'm guessing the Zoho plugin will no longer be working

    The code that remains is as follows:

    /*======================================================
    *                 For Zoho CRM Integrator plugin
     =====================================================*/
    add_action( 'wp_print_scripts', 'my_deregister_javascript', 100 );
    function my_deregister_javascript() {
         if ( is_page(86)||is_page(276) ) {
              wp_deregister_script( 'jquery' );
              if(is_page(86)){
              wp_deregister_script( 'zoho-crm-integrator_pop-up2' );
              }
         if(is_page(276)){
              wp_deregister_script( 'zoho-crm-integrator_pop-up' );
              }
         }
    	 else{
    		 wp_deregister_script( 'zoho-crm-integrator_jquery' );
    	 }
    } );
    remove_action(

    so essentially the code after " remove action" is missing. Is this something that I can somewhat easily put back in place? Hoping it is just "plugin default" code

    Thanks in advance

    http://wordpress.org/extend/plugins/zoho-crm-integrator/

  2. Judge-Mentals
    Member
    Posted 11 months ago #

    I took a semi educated guess at this and changed it to be:

    /*======================================================
    *                 For Zoho CRM Integrator plugin
     =====================================================*/
    add_action( 'wp_print_scripts', 'my_deregister_javascript', 100 );
    function my_deregister_javascript() {
         if ( is_page(86)||is_page(276) ) {
              wp_deregister_script( 'jquery' );
              if(is_page(86)){
              wp_deregister_script( 'zoho-crm-integrator_pop-up2' );
              }
         if(is_page(276)){
              wp_deregister_script( 'zoho-crm-integrator_pop-up' );
              }
         }
    	 else{
    		 wp_deregister_script( 'zoho-crm-integrator_jquery' );
    	 }
    };
    remove_action( 'wp_print_scripts', 'my_deregister_javascript' ); ?>

    this seems to have fixed it up (and a record is still being entered into Zoho)

Reply

You must log in to post.

About this Plugin

About this Topic