WordPress.org

Ready to get started?Download WordPress

Forums

functions.php errors (4 posts)

  1. noisegate95
    Member
    Posted 2 years ago #

    Not being a php person, I come to the web for answers to the "coding and developer" issues. My site is http://blog.noisegate95.com.

    All of a sudden I am getting errors at the bottom of the page. I am using the latest Mantra theme. Could someone point me in the right direction?

    ex. Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration

    Warning: fopen(http://blog.noisegate95.com/wp-content/themes/mantra/style.css) [function.fopen]: failed to open stream: no suitable wrapper could be found in /home/dsdsysn1/public_html/blog/wp-includes/functions.php on line 4452

    Thanks a million.

  2. farzher
    Member
    Posted 2 years ago #

    Wow, line 4452 o_o

    I hate this error... it's caused by your server because it has allow_url_fopen set to OFF.

    You could either try not using fopen by commenting out that line if you don't need it, or look up how to set allow_url_fopen to ON, maybe contact your hosting for support.

    I don't know any simple way of changing it, switching it to on in php.ini or .htaccess never seems to work.

  3. noisegate95
    Member
    Posted 2 years ago #

    That seems to have did the trick. Not sure what all he stuff means, but it got rid of the errors. Thanks for the quick response.

    // $fp = fopen( $file, 'r' );

    // Pull only the first 8kiB of the file in.
    // $file_data = fread( $fp, 8192 );

    // PHP will close file handle, but we are good citizens.
    // fclose( $fp );

  4. noisegate95
    Member
    Posted 2 years ago #

    Ahhh, maybe not so fast. After doing the changes above, when I go into my plugins, each and every one of them are disabled.
    They all have the error:
    The plugin xcloner-backup-and-restore/xcloner.php has been deactivated due to an error: The plugin does not have a valid header.
    When removing the //, everything comes back to normal, and I have to go down the line to activate each one.
    Not good.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.