WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Functions-compat.php disappears in middle of writing post??? (5 posts)

  1. Tfleming
    Member
    Posted 6 years ago #

    Using WP 2.2, I was writing a post. When I went to publish it, I get the following error

    Warning: main(/home2/tfleming/tonyfleming-www/wordpress/wp-includes/functions-compat.php) [function.main]: failed to open stream: No such file or directory in /home2/tfleming/tonyfleming-www/wordpress/wp-includes/functions.php on line 3

    Fatal error: main() [function.require]: Failed opening required '/home2/tfleming/tonyfleming-www/wordpress/wp-includes/functions-compat.php' (include_path='./:/usr/local/lib/php') in /home2/tfleming/tonyfleming-www/wordpress/wp-includes/functions.php on line 3

    I looked up the functions.php file, see that the functions-compat.php file is required, but don't see it anywhere in my directory. It seems to have just disappeared.

    when I try to back up or go to my dashboard, it's all stuck on this error. I can't get in or get back.

    Seeing that I don't have the file, I go back in the WP archives and extract that one file and upload it. But still, I then get this error

    Fatal error: Cannot redeclare timer_stop() (previously declared in /home2/tfleming/tonyfleming-www/wordpress/wp-settings.php:65) in /home2/tfleming/tonyfleming-www/wordpress/wp-includes/functions.php on line 865

    What I don't understand is how the file seems to have disappeared in the middle of my writing a post. Does it have something to do with the auto-save function?

  2. Tfleming
    Member
    Posted 6 years ago #

    more info... I deleted my wp-includes folder and re-uploaded as others have suggested this usually work. Not in this case however.

    Any help would be appreciated as my blog is currently off-line!

  3. colobren
    Member
    Posted 6 years ago #

    I just had the exact same thing happen... at almost the same time.

  4. colobren
    Member
    Posted 6 years ago #

    I upgraded to the latest release and it fixed the problem for me. I'm anxious to know what happened...

  5. Tfleming
    Member
    Posted 6 years ago #

    Thanks colobren. I followed your example and upgraded to the latest addition. Works now, but still leaves me puzzled.

Topic Closed

This topic has been closed to new replies.

About this Topic