WordPress.org

Ready to get started?Download WordPress

Forums

Function & Template (6 posts)

  1. Fad
    Member
    Posted 7 years ago #

    Hi to all! :-)

    First off I would just like to say what a fab bit of kit WP is!! Thanks to all for contributing!

    Now, I have a question that I have been trying to solve all afternoon here, I have spent several hours trawling through posts to find a solution to my problem - but to know avail, so here goes.

    I'm using the FeedWordPress plug-in on one of my sites, and it works great! But, I'm trying to use one of the functions listed at http://projects.radgeek.com/feedwordpress/api#template-api to call the URI of the story pulled onto my blog.

    The code I am using is this, on my main page index template:
    <?php get_syndication_permalink() ?>

    Basically nothing happens at all - I'm sure I'm missing something and if anyone could point me in the right direction I would be very grateful!

    Cheers :-)

  2. Elfminster
    Member
    Posted 7 years ago #

    Hi, you also have to add:

    <?php the_syndication_permalink(); ?>

    Why?

    <?php get_syndication_permalink(); ?> retrieves the value and <?php the_syndication_permalink(); ?> outputs that value.

    For example:

    <?php get_syndication_permalink(); ?>
    <?php get_syndication_source(); ?>
    <?php get_syndication_source_link(); ?>

    Read the <a href="<?php the_syndication_permalink(); ?>">Full Article</a> at <a href="<?php the_syndication_source_link(); ?>"><?php the_syndication_source(); ?></a>

    That's how I do it anyway, works like a charm!

  3. jblow
    Member
    Posted 7 years ago #

    this works well, but for some reason these links are not picked up in the RSS feeds. why is this?

  4. jblow
    Member
    Posted 7 years ago #

    bump (sorry).

    i'm really curious about this though. is there a way to call in the link this way and have it appear in the RSS? possibly for podcasting?

  5. smartcard
    Member
    Posted 7 years ago #

    Anybody success in this mod?

  6. smartcard
    Member
    Posted 7 years ago #

    okay, I fixed the problem by adding the following codes to my single.php of the Presentation -> Theme Editor

    The code is :
    Read the ">Full Article at "><?php the_syndication_source(); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic