WordPress.org

Ready to get started?Download WordPress

Forums

Full Width Page For Twenty Eleven (13 posts)

  1. Absar
    Member
    Posted 2 years ago #

    I am using twenty Eleven and I created a new page for installing mingle forum on it.... And I have successfully Installed this..... But it covers only the central area and not the sides which cause narrowing of forum.
    link to my forum http://www.funfeat.com/programming/forum/
    I know that the sidebars are disabled on twenty eleven default pages but their space remains vacant and is not covered as it should be..... :(
    I am sure there is no problem with the forum, the problem is only with the div containing the forum on the page.
    Please Help me... Wasted my whole day messing up with this.....

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    You would need to create a full width custom page template and apply that new template to your forum page. But dDo not edit the Twenty Eleven theme itself. It is the default WordPress theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. Create a child theme for your changes.

    You can download a pre-made Twenty Eleven child theme from here

  3. Absar
    Member
    Posted 2 years ago #

    Great thanks for quick help.....
    I am still confused about how can i apply the newly created template to my forum page..... i am even unable to find my forum page.....

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Sorry - I've not used Mingle. Is the forum page available to edit via Admin -> Pages?

  5. Absar
    Member
    Posted 2 years ago #

    I can edit by using
    Plugins from dashboard >> editor >> mingle forum

    But i don't know which file to edit

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Try asking the Mingle dev(s) how you can apply a custom page template. I'd suggest posting via http://wordpress.org/tags/mingle?forum_id=10#postform or on http://wpmingle.com/

  7. Absar
    Member
    Posted 2 years ago #

    Thanks a lot for your assistance ......
    I have done that by editing the page through admin panel and selecting "Showcase template" under attributes......

    But this caused a new problem.....
    you can see that now at the bottom of the page I can see the posts of my blog. Which should obviously not appear on the forum page
    please take a look here http://www.funfeat.com/programming/forum

  8. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    you could suppress the recent posts with css;

    .page-id-2 .recent-posts { display:none; }

    add this to style.css of the child theme

    (as you haven't done this yet, create the child theme now ... http://codex.wordpress.org/Child_Themes )

  9. Absar
    Member
    Posted 2 years ago #

    Is this possible without using a child theme I don't want to create a big problem for nothing..... :O

  10. Absar
    Member
    Posted 2 years ago #

    @Alchymyth: Thanks a lot for your suggestion...

    Now I have created the child theme and added the suggested code to style.css but it caused no changes....
    Need Help...

  11. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    this is confusing:

    no sign of a Twenty Eleven child theme and no sign of the added styles either in your forum page (?)

  12. hjustice
    Member
    Posted 2 years ago #

    Hi Absar
    I'm using Twenty Eleven too.
    As you noted, the Twenty Eleven theme displays the Default page template...too narrow.

    There is a Showcase page template that uses the full width, as you discovered however the Showcase page template is designed to show the posts. Our site is like a website, so that Showcase page template works well on the Home page.

    If you don't like that, then that means you can use the Default Page Template and Sidebar Page Template for other pages. Default is too narrow as you noted; Sidebar looks fine.

    Default Page Template is nice because you don't have the sidebars, but why we asked - why so skinny?

    Here is the fix for your child theme's css style sheet to widen the Default Page Template in Twenty Eleven. This fix also corrects the same narrow width problem on a single post page.

    Originally the width was set to 68.9%. At 100% everything looks right.

    It is a lot of css - I placed the entire section in my css because I may need the other elements later. I only changed the width in the last section.
    `
    * Singular */
    .singular #primary {
    margin: 0;
    }
    .singular #content,
    .left-sidebar.singular #content {
    margin: 0 7.6%;
    position: relative;
    width: auto;
    }
    .singular .entry-header,
    .singular .entry-content,
    .singular footer.entry-meta,
    .singular #comments-title {
    margin: 0 auto;
    width: 100%;
    }
    '
    Just in case, I wanted to add - maybe you want to check and be sure to select your child theme instead of Twenty Eleven through the Admin panel as part of placing it into action? That's what points the system to use your child theme's css. I've got the import trick at the top of mine to bring in all of Twenty Eleven, then this css sits below that to customize my site.

  13. .jess.
    Member
    Posted 1 year ago #

    Thanks hjustice, that worked for me.
    @Absar: I got the full 100% width by setting the margins to 0
    (ie. change this line in the code above to margin: 0 0 0 0;)

    .left-sidebar.singular #content {
    margin: 0 7.6%;

Topic Closed

This topic has been closed to new replies.

About this Topic