WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Full size Image Instead of Default Thumbnail in Single Post (5 posts)

  1. Mike Matenkosky
    Member
    Posted 1 year ago #

    In my testing site: http://sandbox.imagesinthebackcountry.com/portfolio/ When you click on the "MLA Gallery" I see a thumbnail. Is there any way to show the full size image like all of the other Portfolio Galleries. Obviously the other Portfolio Galleries are not created using the Media Library Assistant.

    Thanks!

    http://wordpress.org/extend/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Let me restate your issue to make sure I understand it. You posted a link to your "Portfolio" page. When I click on any of the images on this page I go to a page that should show the individual image in full size. The images for galleries like "Yosemite" work correctly, but the images in the "MLA Gallery" show a thumbnail size image.

    It looks like the single-image pages for galleries like "Yosemite" are composed with some shadowbox shortcode/plugin, but the images in the single-image pages for "MLA Gallery" are composed with [mla_gallery]. If that's right, I think the solution is to add size=full to the [mla_gallery] shortcode. Here's the relevant section of the MLA documentation:

    Size
    The Size parameter specifies the image size to use for the thumbnail display. Valid values include "thumbnail", "medium", "large", "full" and any additional image size that was registered with add_image_size(). The default value is "thumbnail". You can use "none" or "" to suppress thumbnail display and substitute the item title string for the image/icon.

    The [mla_gallery] shortcode supports an additional Size value, "icon", which shows a 60x60 pixel thumbnail for image items and an appropriate icon for non-image items such as PDF or text files.

    If I've misunderstood the issue or that's not the answer, having a look at the page source code would be helpful. Let me know if you need more help with this issue.

  3. Mike Matenkosky
    Member
    Posted 1 year ago #

    Yes, that's correct. This is what I have and it now shows a medium thumbnail.

    [mla_gallery size="full" ids="2266"]

  4. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    I just had another look and now I see that the full-size image is there, but I forgot to add that you must specify columns=1, because the default value of three (3) is restricting the image to 33% of the page width - my mistake.

    You might also want to add mla_margin=0 if the default value of 1.5 (percent) is more than you want. See the "Gallery Display Style" section of the documentation for more information.

    Hope that does it for you.

  5. Mike Matenkosky
    Member
    Posted 1 year ago #

    That did the trick. It was too easy...LOL!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.