WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Full Screen of Youtube Embeds not working (5 posts)

  1. WebKJGor
    Member
    Posted 1 year ago #

    This is about Jetpack's "Shortcode Embeds" module.

    When viewing an embedded Youtube on a post, the Full Screen button usually on the bottom corner of the video is missing. This forces the reader to click on the Youtube button and away from the blog post to view the video in fullscreen.

    The issue only appears if the reader is using Chrome and is logged into their Youtube account. Tested on Mozilla and IE, no problem.

    I did not make any changes, I think Youtube recently edited their embed code and did something with the fullscreen variable, can the team at Jetpack update the code please?

    Thanks,
    Jim

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I tried to reproduce the issue on my test blog, and the Fullscreen option seems to be displayed properly on my end.

    Could you paste the shortcode you used in your post here?

    Could you also post your site URL, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  3. WebKJGor
    Member
    Posted 1 year ago #

    Hi,

    I found the problem. My Youtube account is enrolled in the HTML 5 trial. HTML5 doesn't support fs=1 which you are using for the fullscreen embed. When I opted out of Youtube's HTML 5 trial, the fullscreen button became available.

    Can you change the Youtube embed code so that it allows HTML5 and Flash players to view the fs button? I think using allowfullscreen="true" instead of fs=1 might work.

    Thanks,
    Jim

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the extra details!

    I tried to reproduce by joining the HTML5 trial, but it seems the problem happens with all video embeds, whether you use Jetpack shortcodes or not.

    I tried the 3 following embed methods:

    Pasting the URL on a separate line (oEmbed):
    
    http://youtu.be/vLUFL3KoAr4
    
    Pasting the embed code:
    
    <iframe width="853" height="480" src="http://www.youtube.com/embed/vLUFL3KoAr4" frameborder="0" allowfullscreen></iframe>
    
    Using Jetpack shortcodes
    
    [youtube http://youtu.be/vLUFL3KoAr4]

    When I was part of the HTML5 trial, the fullscreen option disappeared from all videos, whether I used Jetpack or not.
    When I left the HTML5 trial, all fullscreen options appeared again.

    Youtube's HTML5 page also mentions that Fullscreen support is partially implemented.

    I'm afraid there is not much we can do on our end. Once Youtube HTML5 supports fullscreen in embedded players, the button should appear in all your videos.

  5. zstructures
    Member
    Posted 1 year ago #

    Try adding allowfullscreen="true" at the end
    for e.g.
    [youtube https://www.youtube.com/watch?v=Ipn5K_M3Ywg&w=640&h=480 allowFullScreen="true"]

    This is how i fixed on my blog and it worked out.
    Check the video embedded at following link:

    http://ztwocents.wordpress.com/etabs2013/

    Hope it work for you!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic