WordPress.org

Ready to get started?Download WordPress

Forums

Forever
Full Page Template option doesn't work (13 posts)

  1. lisamv
    Member
    Posted 1 year ago #

    Using the Forever Theme, when I set the Home page (static page) to 'show latest 4 posts' which IS a theme option all the widgets on the sidebar move down the page underneath the 4 posts. I want to remove the sidebar widgets from this page only, but when I set any page to 'full page template' it DOESNT WORK, completely ignores the selection even though it's there to choose, makes no sense whatsoever.

    I've followed other forum instructions on how to remove the sidebar for a specific page only using .php and css suggestions and NONE of them work. If there's no way to do this then I'm gonna trash this theme, it's not worth the time to figure out this huge 'flaw' in the theme. Sorry, just frustrated at this point with the theme not working correctly. Does anyone know the right way to remove the sidebar from the home page only?

    Thanks

  2. Kapil Gupta
    Member
    Posted 1 year ago #

    Although I don't think I am a WP master but I encountered similar issue on one of the famous theme & this is what I did (as per my best memory; other's can correct me if I missed/messed anything)

    Go to Edit Theme option and locate the .php file which is controlling the home page (commonly index.php). The <div> which is holding the content box might be mapped to wrong css element (like 'box-left' or similar). You just need to find the correct css element (like 'full-width' or similar) and replace original <div class> with this css element ... should be solved.

  3. lisamv
    Member
    Posted 1 year ago #

    Sorry, don't understand what you mean or how to do this.

  4. Kapil Gupta
    Member
    Posted 1 year ago #

    ok ... no issues

    in your index.php file, locate the code where main content is getting displayed. It should be inside <div> box, like <div class="...something...">. Now there are two possibilities (1) This 'something' defines the style of your content box and pushing it on one side, and displaying sidebar (2) There should be one more <div> like <div class="sidebar"> (or something similar)

    Hit & Try:
    1) Identify correct element from style.css which actually show the content on entire page and replace "...something..." with that correct element.
    2) Delete <div class="sidebar"> (or similar) from php file.

    Please share your live website URL. I might try to dig it myself.

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @Kapil Gupta -

    It's never a good idea to modify theme files directly - as those changes will be lost when the theme is updated. Use a child theme to make those kinds of changes.

  6. lisamv
    Member
    Posted 1 year ago #

    here is the url to the site. Don't really understand what you said in your post and WPyogi is right :) What it boils down to is there is a option to set the page as 'full-width, no sidebar' HOWEVER it does not accept the setting, nothing changes when you choose it.

    http://artfulmusestudio.com/workspace102/

    Thank you!

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Hi Lisa - I think that only works with a static home page - not posts on the page - I tried it and it did work on a test site.

    What do you have under Settings > Reading for the home page?

  8. lisamv
    Member
    Posted 1 year ago #

    Thanks WPyogi...I have that setting set to 'static page' with 'post page' set to 'Home'.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  10. Kapil Gupta
    Member
    Posted 1 year ago #

    my bad ... apologies ;) just thought of helping the user.

  11. Kapil Gupta
    Member
    Posted 1 year ago #

    checked your portal, create child theme or manage settings but in actual below is the bad guy
    ---
    <div id="secondary" class="widget-area" role="complementary">
    ---

    Please do as suggested by WPyogi

  12. lisamv
    Member
    Posted 1 year ago #

    I read that page but don't see what I'm doing wrong as I mentioned, it is set as a static page. The Theme options allows you to choose show latest 4 posts but doesn't tell you how to get rid of the sidebar that then falls below these four posts once you choose that theme option.

    Maybe I'm not explaining it right, I don't know :(

  13. paulwpxp
    Font hero
    Posted 1 year ago #

    http://codex.wordpress.org/images/1/18/Template_Hierarchy.png

    When setting a Page to be a Blog Home ( main post listing page ), it will use home.php if not found then index.php. In this case, it use index.php because theme doesn't have home.php.

    So the Page Template assigned to that Page will never get used. It will use index.php which has all the magic stuff including the 4 posts thing.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.