WordPress.org

Ready to get started?Download WordPress

Forums

Portfolio Press
Full page Single Post (10 posts)

  1. lisadragon
    Member
    Posted 1 year ago #

    When I click a photo on Portfolio page, I would like to see the image full page with no sidebar. How do I do this?

  2. editability
    Member
    Posted 1 year ago #

    Hi Lisa,

    What theme are you using?
    What do you currently see when you click now?
    Do you have a link to your site?

  3. lisadragon
    Member
    Posted 1 year ago #

    hi. its the Portfolio Press theme..

    My site http://dragonbond.com

    I collected the "Portfolio photos" under page "Project 365". So far theres 5 days, 5 photos..

    Once i click a photo it takes me to the individual page but I dont want to see the sidebar.. I'd rather see a full width (no sidebar) page...

  4. editability
    Member
    Posted 1 year ago #

    It's difficult to know without looking at your backend. Two things to try:

    1. Each portfolio item should have it's own page. Without looking at your backend, I would guess that you would navigate to the portfolio section and click "View All" or something like that. When you click on this page, on the right side, under the "Publish" or "Update" button, you should see an option that allows you to select the page templates. Is there a "Full Width" template there? If so, select that and click on "Update" or "Publish"

    2. Perhaps this is controlled from your theme options page. In your theme options, is there a section to manage the portfolio settings? If so, see if you can control the sidebars there.

  5. Bled05
    Member
    Posted 11 months ago #

    I have the same issue that lisadragon has and for each portfolio item, unlike a page item, there is no option to set it to full page. The theme allows you to set a global full-width page from the theme options menu but this removes the sidebar from every page. I love this theme but this is one feature that I really dislike. I want to have my sidebar on my home/posts page and then have each portfolio item full page. I can create new pages as full page, but then they will not link from my portfolio items. I know this sounds confusing if you've never used this theme. I have modified the single-portfolio.php page to not display the sidebar but not being a programmer with very limited .php skills or knowledge, I cannot figure out how to make the single portfolio page display my content full-width. I wonder of the Portfolio + theme has this option because it would be worth the $25 to me if it did.

  6. Devin Price
    Member
    Theme Author

    Posted 11 months ago #

    Portfolio+ does not have that option either.

    If you've removed the sidebar on portfolio posts you're half way there.

    The next thing would be to add to styles.css:

    .single-portfolio #content { max-width: 100%; float:none; }
  7. stelx
    Member
    Posted 9 months ago #

    @Bled05 i have the same problem too. Can you please tell me about the modification you did at single-portfolio.php? adding the code Devin proposed, did the problem solved?

  8. stelx
    Member
    Posted 9 months ago #

    i erased the <?php get_sidebar(); ?> from single-portfolio.php and then i added to style.css

    .single-portfolio #content { width:100%; max-width: 980px; float:none; }

    problem solved ;-)

    thank you all for the infoz

  9. Bled05
    Member
    Posted 8 months ago #

    Thanks for the info! I just now saw these posts.

  10. breezewp7
    Member
    Posted 7 months ago #

    Wanting the same look as @Blend05 and @stelx so tried their combined solutions, but not working. Sidebar disappears OK but content still anchored to the left of the display, tried adding margin-left:auto; and margin-right:auto but this also did nothing. Can you tell me how to align the portfolio item to the center of the display?
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic