WordPress.org

Ready to get started?Download WordPress

Forums

Events Made Easy
[resolved] Full Calendar showing year 0 after upgrade (8 posts)

  1. vvvv
    Member
    Posted 1 year ago #

    HI

    Since upgrading to the ver 1.0.8, my full calendar is showing up with the month and year of: December 0

    Is there anything I can do to get me back to the correct day and year here? The widget calendar does show Jan 2013, so that one seems ok.

    Thank you for any help!

    http://wordpress.org/extend/plugins/events-made-easy/

  2. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Example site and theme info please. I'm guessing there's a javascript issue that prevents the correct info from being fetched. Please also check your browser console for javascript errors.

  3. vvvv
    Member
    Posted 1 year ago #

    yep.
    Actually am getting just that!

    Error Console:

    Timestamp: 1/23/2013 6:53:10 AM
    Error: ReferenceError: eme_ajax is not defined
    Source File: http://rhodygarden.com/cms/wp-content/plugins/events-made-easy/js/client-clock.js?ver=3.5
    Line: 4

    Clicking in gives:
    // Don't wait for DOM ready.
    var now = new Date();
    jQuery.post(
    eme_ajax.ajaxurl, {
    action: 'client_clock_submit',
    client_unixtime: Math.round(now.getTime() / 1000), // make seconds
    client_seconds: now.getSeconds(),
    client_minutes: now.getMinutes(),
    client_hours: now.getHours(),
    client_wday: now.getDay(),
    client_mday: now.getDate(),
    client_month: now.getMonth()+1, // make 1-12
    client_fullyear: now.getFullYear() },
    function(ret) {
    if (ret == '1') {
    top.location.href = self.location.href;
    }
    }
    );

  4. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    I need to check this. For now, just disable the option to use the client clock in the EME admin settings page.

  5. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    If you're willing to test (I'm not home yet): move in events-manager.php the line 41 (starting with "wp_localize_script") just after line 52 (starting with "wp_enqueue_script") and see if that resolves it if you leve the client clock option on in the EME settings.

  6. vvvv
    Member
    Posted 1 year ago #

    Beautiful!!! Thank you! Yes, it worked. I left the client clock enabled and moved line 41 to after 52 and I now have a calendar that shows the correct month, day and year, and with the "today" cell indicated.

    Really is a flexible plugin and I will eventually figure out to to use all of these options - thanks so very much!!

  7. vvvv
    Member
    Posted 1 year ago #

    Resolved!

  8. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for letting me know! Changed in the code, and will of course be in the next version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic