WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Ftped the files /install.php only shows white page (8 posts)

  1. ckheaton
    Member
    Posted 4 years ago #

    New to this -

    I have tried installing WP on 2 different databases now with the same error - http://www.thedomain.com/blog/wp-admin/install.php is a white page.

    Both installations are through the same hosting provider who says some of their other users have WP installed. Both DB's have different username/passwords as their FTP.

    What is the next step?

  2. pritchet1
    Member
    Posted 4 years ago #

    My wp-config.php was missing the ?> ending, so I added that. I still get the white screen too.

    I ran the phpinfotest.php program and found the MySQL links set to "0". I have asked the host to look into it, since they are the ones who set up the database.

  3. s_ha_dum
    Member
    Posted 4 years ago #

    Databases don't have an 'ftp'. I'm not sure what you mean. Two databases, different usernames and passwords? Two separate install directories using different FTP servers?

    Unless you've registered 'thedomain.com' how about posting your web address? Fake URLs are counterproductive.

  4. ckheaton
    Member
    Posted 4 years ago #

    The reason I mentioned: Both DB's have different username/passwords as their FTP -
    The database's username/password were originally set up with the same username/password as the domain's FTP - I thought that may have been causing the problems because it could be a security issue. I have told the host to change this, however it didn't solve the problem when I updated the configuration file and re-uploaded the entire folder.

  5. pritchet1
    Member
    Posted 4 years ago #

    The one I am working on is generationsofwarriors.us without the subfolder of blog. And ditto with ckheaton

    Is the white page an error or are we being blocked to not see the admin login screen?

  6. pritchet1
    Member
    Posted 4 years ago #

    "Well I checked everything and all of it including the permissions should be set up correctly on our side. I check the logs and we are getting an error from your config file which says:

    "[error] PHP Parse error: syntax error, unexpected ';' in /private/Network/Servers/hermes.local/Volumes/XRAID01/Users/bruddamon/Sites/wp-config.php on line 77"

    This sounds like something simple like a missing semi-colon after the line of code on line 77.

    I reinstalled everything.

    The host said that line 77 had an error in wp-config.php, so I redid the line -

    define('ABSPATH', dirname(__FILE__) . '/');

    Then I refreshed. I actually got a WordPress text page in the install.php link finally!

  7. s_ha_dum
    Member
    Posted 4 years ago #

    Good. I'm glad you got it worked out. The solution makes perfect sense. Apparently your host has PHP's error echoing turned off. That's a good thing, really, from a security standpoint. Makes debugging tough though.

  8. ckheaton
    Member
    Posted 4 years ago #

    I finally have success, but I did have to work with the hosting company as well - line 77 was coming up again and again as an error.
    It was a permissions problem.

Topic Closed

This topic has been closed to new replies.

About this Topic