WordPress.org

Ready to get started?Download WordPress

Forums

FTP Plugin Updates?! (6 posts)

  1. clicktheo
    Member
    Posted 5 years ago #

    Hello,

    I have been growing increasingly frustrated with my WordPress installation recently due to issues with updating plugins. Allow me to explain....

    When I go to the plugins tab and select the 'update automatically' option under a plugin that requires an update, a FTP Information screen appears requesting my FTP account details etc. Whilst I don't have a problem with this, updates over FTP take time and I am aware that when I was on my previous host, I didn't have to do this. The files were simply downloaded and the plugin was updated in one or two clicks without any FTP information having to be exchanged.

    I get the feeling that I may have configured my VPS incorrectly, and would very much like to be able to simply update a plugin in a matter of a few clicks without having to add any FTP details. Can anyone help?!

    For your reference, my VPS specification is listed below:-
    * 512Mb guaranteed RAM, 1024Mb burst RAM
    * Parallels Power Panel (Virtuozzo)
    * CentOS 4
    * cPanel 11 & Fantastico
    * Apache 2.0 or 2.2 (I can't remember)
    * PHP 5 & MySQL 5

    Thanks!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The FTP option appears when the web server process is unable to write files to your local installation properly, as the correct owner and such.

  3. clicktheo
    Member
    Posted 5 years ago #

    Well, I seem to have set the folder permissions correctly - is there any other procedure that I can carry out to get this installation working?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    What user is the webserver process running as? Are you using suPHP or just regular PHP?

    I always prefer to install suPHP, as it makes things simpler for me in the long run. Most systems include it as part of their package repository, so installing it should be as easy as an apt-get or yum command. However, if you are using suPHP, then never make a website's files belong to root. That way madness lay.

    Alternately, if this is not a shared server, then simply making the apache user own the website files might do the trick as well.

  5. clicktheo
    Member
    Posted 5 years ago #

    I am running suPHP, and Apache seems to be making the files run as the user. Or, at least my CPU Usage screen seems to be listing it like that:-

    clickth click-theo.com 0.06 0.23 0.0

    It still doesn't seem to be working....any other ideas?

  6. Mike Castro Demaria
    Member
    Posted 5 years ago #

    You just need to be sure your HTTP user can access to the files for update.

    For example if apache is running as nobody, just chown nobody as owner of the files. It's less secure than the FTP process, but you can use the link for plug-in update

    EX : chown -R nobody:nobody ./wordpress

    I hope it will help.
    mike

Topic Closed

This topic has been closed to new replies.

About this Topic