WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] FTP error installing updates on localhost (10 posts)

  1. Bloke
    Member
    Posted 1 year ago #

    I am trying to update my WordPress and plugins on my localhost. Getting this error and asking for ftp info: There was an error connecting to the server, Please verify the settings are correct.

    I verified my hostname, ftp user and password in wp-config Is there anything else I can look for to fix this. I am able to log into the database in phpmyadmin with the credentials.

  2. phillbooth
    Member
    Posted 1 year ago #

    Download a new version on to your machine unzip and then remove everything in the wp-config/themes folder

    Copy and paste over your old install.

  3. phillbooth
    Member
    Posted 1 year ago #

    If that does not work try renaming the wp-config file

  4. Bloke
    Member
    Posted 1 year ago #

    There is no folder called wp-config/themes I created a new wp-config file but still can't install the update. It did allow me to update the default themes.

  5. Bloke
    Member
    Posted 1 year ago #

    It was a permission issue. I had to change it in IIS and edited the folder of my site. Now it works.

  6. phillbooth
    Member
    Posted 1 year ago #

    IIS wow try using xampp might be a little eaiser

  7. Bloke
    Member
    Posted 1 year ago #

    What is the benefit of xampp?

  8. phillbooth
    Member
    Posted 1 year ago #

    IIS is from Microsoft they push .net that is a different C language to PHP, IIS can run PHP with an additional module but not very well.

    To put it bluntly your trying to run WP built for PHP that should run in a Linux environment as opposed to a Windows environment. Its like trying to run PC software on a Mac, it crazy.

    You need the right tools for the right job. Xampp will install Apache (so you can use this rather than ISS) server and MySQL, if not already installed.

    Apache is designed to run PHP from the ground up, most website running WordPress run on Apache.

    http://www.apachefriends.org/en/xampp-windows.html

  9. Bloke
    Member
    Posted 1 year ago #

    If I already have PHP, MySQL and PhpMyAdmin installed, do I have to remove them and install them again with Xampp?

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Yes. Re-install them with Xampp. Or try using EasyPHP which comes bundled with PHP & MySQL.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.