WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
FTP credentials don't allow to write to file /.htaccess (15 posts)

  1. jeskey
    Member
    Posted 1 year ago #

    I received this error when trying to install the plugin - FTP credentials don't allow to write to file /.htaccess.

    I called support at BlueHost - they worked with me for about 30 minutes but they do not know how to fix this. They say this plugin wants to write to root folder of server "/". I am on a hosted server and I have this website as an add-on domain ( sub folder of public_html ).

    I hear this plugin is great - hope I can get it working although proper configuration looks a bit daunting.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. dm5k
    Member
    Posted 1 year ago #

    I am getting this same error. I don't know how to fix it. I tried hitting Update via FTP to "use FTP form to allow W3 Total Cache make it automatically." and nothing happens.

  3. new_B
    Member
    Posted 1 year ago #

    Try updating .htaccess manually by adding the rules provided in the same message.

    In my case, after doing so the error still displays though...not sure if it's designed to always show?

  4. dm5k
    Member
    Posted 1 year ago #

    You mean copy and pasting everything in that message? If that works then why doesn't the error message go away for you?

  5. Kimberly Gypsy LoSavio
    Member
    Posted 1 year ago #

    I am getting this error:

    "W3 Total Cache error:It appears Minify URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately minification will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.
    Technical info "

    for both minify and page cache

    Contacted my hosting provider and all my files are rewriteable ... this is annoying and extremely frustrating. as obviously the problem is not with my provider. I certainly hope someone can either fix this or at least tell us how to fix it!

  6. art9037880
    Member
    Posted 1 year ago #

    Got a similar error.
    Tried to manually update htatstsess, did not help.
    Then, when checking for compatibility (button "compability check") noticed one strange thing - it does not see the absolute path to the file. Ie: /home1/.../public_html/.htaccess and tries to write to a file in the root of the server.

  7. databell96
    Member
    Posted 1 year ago #

    Let me throw my hat in the ring on this thread. I'm experiencing the same problem on LunarPages. Same deal. Funny, because I've installed W3TC on other LunarPages accounts and this hasn't happened.

  8. jeskey
    Member
    Posted 1 year ago #

    What really seems strange is the lack of any support since so many seem to be experiencing this. I am currently paying someone who is hopefully more capable than me to install and configure the plugin. I will report back anything I learn.

  9. jpw94
    Member
    Posted 1 year ago #

    having the same issue on a particular site and I don't see specific information on conditions which would recreate this. I'm guessing it's something that can be determined and a workaround can be defined if not an eventual enhancement to make it easy to make the right adjustments.

  10. Sam
    Member
    Posted 10 months ago #

    BUMP!

    Same situation as art9037880...

    Got a similar error.
    Tried to manually update htatstsess, did not help.
    Then, when checking for compatibility (button "compability check") noticed one strange thing - it does not see the absolute path to the file. Ie: /home1/.../public_html/.htaccess and tries to write to a file in the root of the server.

    PLEASEEEEE HELPPPP!!

  11. bdvalenzuela3@gmail.com
    Member
    Posted 10 months ago #

    I have experienced this and fixed it. Here is how I did it. I went in to my FTP to change my .htaccess file permissions from read-only to writable. Then, I made the changes I needed to so that W3 Total Cache would work, then I returned my .htaccess file to read-only permissions.

    1. Log in to your website via FTP (I use FileZilla, but you can use any other FTP client or use an FTP file manager like what GoDaddy offers, you can probably access your site files in your FTP in cPanel as well).

    2. Edit permissions of your .htaccess file. I'm using the Bulletproof Security plugin, so that automatically prevents any and all changes to my .htaccess file. Some other plugin is likely doing that for you too. My permissions were set to 404 (read-only, you can use 0404 if your FTP client requires four digits), I had to edit them so that my .htaccess file is writable. I set the permissions to 705 (0705). Not sure how you do this with Windows hosting (which isn't that great for WordPress anyway, you may want to consider switching to Linux hosting if you aren't already on it), but you can make your .htaccess file, and all other files and folders, writable with Windows hosting.

    3. Once I made my .htaccess file writable, I just copied and pasted the changes that W3 Total Cache wanted to make into the top of the .htaccess file. (For Bulletproof Security, I had to go to edit functions.php to turn off the annoying BPS security warning that shows up in my WordPress dashboard. Google it for more info if you're using BPS. If you aren't using BPS, don't worry about this part in parentheses.)

    4. Optional, return your .htaccess file to read-only permissions (404 or 0404). If you use lots of plugins that edit your .htaccess file, you'll either have to leave your permissions at 705, or you'll have to do this manual editing process every time you change your .htaccess file. Changing your .htaccess file to read-only mode is better from a website security standpoint, but it's more hassle to change around. Leaving it writable is a little less secure, but is more convenient to make changes.

  12. alorenzo
    Member
    Posted 9 months ago #

    Same here. Probably the Better WP Security changed the permission and that was stoping W3 TC from properly initialling. I deactivated the security plugin temporarily and changed manually the .htaccess and wp-config.php permissions.

    After the permission changes worked but when reactivating Better WP Security, it fails again.

  13. popgirl23
    Member
    Posted 9 months ago #

    I think I just fixed this.

    In the W3TC settings I set everything the way I liked it, then copied the .htaccess code created under General Settings.

    Then in Bulletproof Security I went to the htaccess file editor tab, then clicked the Your Current Root Htaccess tab and copied the W3TC code to the top of what's there. Save. Then I had to refresh the browser to clear plugin messages. Everything seems to be working now.

  14. encrypt1on
    Member
    Posted 9 months ago #

    where is the setting exclusion settings in WP Security, I love the plugin however it takes over .htaccess and I can't find the option.

  15. razmi
    Member
    Posted 3 months ago #

    WORKED :D

    I am using w3 total cache plugin and was showing error "FTP credentials don't allow to write to file /.htaccess "

    Thanks to [ email deleted, do not post those here ], just wanted to contribute; go to Filezilla open the path containing .htaccess file right click on that file , you can see "Owner Persmission" put the check on checkbox in both "Read" and "Write" then click OK. Then go to w3 total cache plugin page you can see the plugin in enabled and no problem at all. I am also using iTheme security plugin, then i activated the security plugin, and it works great.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic