WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
FTP credentials don't allow to write to file - Continuous notification (7 posts)

  1. gr33nman
    Member
    Posted 1 year ago #

    All wordpress configurations are up-to-date and current.

    I'm getting this message now from W3 Total Cache

    FTP credentials don't allow to write to file /home/myname/mysite.com/.htaccess

    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.
    Please execute commands manually
    or use FTP form to allow W3 Total Cache make it automatically.

    There's an image, linked below. Regardless of whether I manually add in the content as directed to my .htaccess file or not, I get this message. I wonder if it may be conflicting with BulletProof Security, but cannot be sure, since other people are having similar problems and may not also have BPS.

    http://www.flickr.com/photos/71276004@N04/sets/72157634212351379/with/9084543975/

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. scoobydooo9r
    Member
    Posted 1 year ago #

    I am having the same problem, and it seems like it started right after I upgraded BPS. The problem goes away if I put BPS in default mode. I can't be entirely sure that it is BPS, but it sure seems like it is the cause.

  3. BuyManThings
    Member
    Posted 1 year ago #

    I would definitely say it's your Bulletproof Security settings. This is also applicable to WP Better Security.

    There is a setting/tweak related to removing write permissions from .htaccess and wp-config.php, turn that off and you should be good to go.

    http://http://buymanthings.com/

  4. AITpro
    Member
    Posted 1 year ago #

    BPS has a lock and unlock root .htaccess file buttons on the BPS Edit/Upload/Download Tab page. If you would like to let another plugin write to your .htaccess file and it is locked you would need to unlock it to allow the other plugin to write its htaccess code to the root .htaccess file.

    There was a previous issue with the BPS AutoLock and file permissions checks during upgrade auto-updating that was fixed in BPS .48.9. What was occurring is that the root .htaccess file permission was being cached so the check whether to automatically lock the root .htaccess file again after the auto-update completed was failing. So now that it is working correctly you would need to choose Turn AutoLock On or Turn AutoLock Off on the BPS Edit/Upload/Download page. Most hosts allow you to lock your root .htaccess file with 404 Read-Only permissions, but a few do not. If you lock your root .htaccess file and your website crashes you will need to FTP to your website and change the permissions of the root .htaccess file from 404 to 644 file permisssions.

  5. AITpro
    Member
    Posted 1 year ago #

    Typo/correction made above: had 403 on the brain. changed "403" to 404 above. ;)

  6. mbrighton
    Member
    Posted 1 year ago #

    Thanks for info. Yes, I did what AIT Pro said with Bulletproof security and it worked to fix WP3cache.

  7. gr33nman
    Member
    Posted 11 months ago #

    I've removed the lock on BPS. This part of W3TC works properly now. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic