WordPress.org

Ready to get started?Download WordPress

Forums

Ftp (8 posts)

  1. Astakhov
    Member
    Posted 2 years ago #

    Hy i already install webserver phpadmin in my computer and wordpress but when i update the theme they ask me th hostname and ftp username and pass so can you helme how to get it
    here the picture

    and this for php admin
    http://a6.sphotos.ak.fbcdn.net/hphotos-ak-snc7/c50.0.403.403/p403x403/391176_107597636056216_390577359_n.jpg

  2. cyclito
    Member
    Posted 2 years ago #

    This is also my problem I don't understand what I've to do.
    Many people have to struggle with this.
    I know that I need e server ftp in local but I don't know how to customize it ?
    Just some tip ?
    Thank you

  3. Astakhov
    Member
    Posted 2 years ago #

    ow also you help us please

  4. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    This happens if the webserver is not running under the same user account that owns the WordPress files

    For XAMPP, you should be able to use the default ftp settings

    server localhost
    user nobody
    password xampp

    For different servers you'll need to find out the details for a user account.

  5. Astakhov
    Member
    Posted 2 years ago #

    but can you tell me how to install wordpress under xampp in ubuntu and thanks

  6. cyclito
    Member
    Posted 2 years ago #

    For different servers you'll need to find out the details for a user account.

    Do you know how to find out ?
    Thanks

  7. cyclito
    Member
    Posted 2 years ago #

    Sorry if I give some details maybe I could have a better help.
    Operative system ubuntu, server Apache2, ftp vsftpd.
    If someone can help and other things will be useful I'll give you thanks

  8. ianhaycox
    Member
    Posted 1 year ago #

    As usual there are loads of different ways, but what I do is,

    1. Install the Apache module to allow Apache to run as my user.

    $ sudo apt-get install apache2-mpm-itk

    2. Create a virtual host, by creating a file in /etc/apache2/sites-available/mysite with the contents,

    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    
    	ServerName mysite
    
    	DocumentRoot /home/ian/Projects/mysite
    	<Directory /home/ian/Projects/mysite>
    		Options Indexes FollowSymLinks MultiViews
    		AllowOverride All
    		Order allow,deny
    		allow from all
    	</Directory>
    
    	<IfModule mpm_itk_module>
    	AssignUserId ian ian
    	</IfModule>
    
    	ErrorLog /var/log/apache2/mysite-error.log
    	CustomLog /var/log/apache2/mysite-access.log combined
    
    </VirtualHost>

    Adjust your paths and userid as appropriate.

    3. Edit /etc/hosts to append mysite to localhost

    127.0.0.1 localhost mysite

    4. Create the 'Projects' directory above, e.g. /home/ian/Projects/mysite and dump a 1 line index.html file there with hello world

    5. Enable site and restart Apache

    $ sudo a2ensite mysite
    $ sudo /etc/init.d/apache2 restart

    6. Browse to http://mysite and see 'hello world'

    Now that's working you can follow the 5 minute WordPress install to create an installation in mysite. For example,

    $ rm -rf /home/ian/Projects/mysite
    $ cd /home/ian/Projects/
    $ unzip wordpress-x.x.x.zip
    $ mv wordpress mysite
    $ mysql -uroot -psecretpass
    mysql> create database mysite;

    Browse to http://mysite and follow the instructions. Automatic updates and plugin installs all work without prompting for FTP information because all the files in Projects are owned by you and Apache is running as the same user.

    Rinse, repeat for more sites.

    I've got about 20 virtual hosts with WordPress, Drupal etc. installed in each Projects directory, for theme, plugin development

    Ian.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags